Open search

Samsung Smart TV stopped connecting to internet (wifi and Ethernet)

New Member

Our  Smart TV lost its connection to our network on Thursday evening.  First, we went through  wireless set up, chose our network, entered authentication key, but couldn't and wouldn't connect at all.  Second, we assigned a static IP and that didn't work either.  When we decided to connect using mobile phone hotspot, then it connected with no problem.  The option to use the hotspot was not a desirable one since we didn't want to use up data. 


So, we decided to turn on the SSID-guest with WPA disabled on the router to see if we can get internet connection that way.  We went back to wireless set-up and chose the SSID_guest network.  We were able to establish connection to the home network, but there was still one problem: we were connected to the router, but not the internet.  We went into Network Status> IP Settings.  On IP Setting, we switched and chose "obtain automatically" to "enter manually", then back to "obtain automatically" and  performed the same for DNS Setting, then hit "OK".  It worked! But, we didn't want to use the guest SSID so we switched back to the regular SSID, enter authentication, and performed these steps again: Network Status> IP Settings, as above.  It worked and we got our connection back to our regular home network.

New Member

I know how to fix this, I found that the TV was connected to the WiFi (router) in the routers settings but the TV was also displaying no internet connectivity - it was in a state of connected and not connected at the same time...we fixed this by connecting to hotspot on our iPhone which broke any and all connection to our usual WiFi (router), we then disconnected from our hotspot on the TV and reconnected to the usual WiFi (router) and it worked , hope this works for you too.

New Member

If you have a dual band router (it will say 2.4ghz and 5ghz on it) then split the networks apart. Don't have any special characters in the wifi name or password not even a hypen, stick to letters and/or numbers for wifi name and password. I've had it happen where the tv wont connect even if there is a single hypen or dot in the name, i.e "mywifi-24 or mywifi2.4". After splitting the 2.4 and 5ghz ssid's and not using any special characters I have had significantly less problems. I do get the random wont connect or no wifi names show up and a 2 min powercycle (actually unplugging the tv) works. With powercycling I stick to a strict minimum 2 minutes but that's just me. I have next to no issues with devices like phones, computers, tablets, game consoles connecting. Streaming sticks and smart tvs a power cycle tends to fix them tho it seems to be some kind of power management issue that stops the wireless adapter from working sometimes. 

New Member

Have read all the posts on this. I tried numerous the fixes suggested. Everything I tried did not work. No matter what I tried, I could not connect to the internet. Then I came across one post from way back that said hold the power button down until Samsung log appears. Desperate, I thought couldn't hurt.  It worked. When I tried to reconnect, it found my network, which it wouldn't do before, I had to manually enter everything, entered my password and I was back on. It was especially frustrating because I have Google home and none of the functions would work through the device. All's right with the world now. Hope this helps all or at least some of you.


FYI a new firmware has been released for the (2018) QLEDs (at least in Europe). Currently only available over USB update, no OTA yet. The new version is 1251.0.

Check out my last post:

New Member

I have netgear Nighthawk  the Samsung TV wouldn't connect to the internet but would to the router, tried a manual method of ip and dns, wireless and wired, nothing would work. Finally I opened the Nighthawk app on my phone and looked for all devices on the same wireless network as the TV and noticed that the router was showing the TV was there but was blocked, so I clicked allow in the app and the TV instantly connected, problem solved. Crazy, no idea when the router decided to start blocking the TV as it was connected before but it's all good now. 

New Member

I was having the exact same problem. We changed the internet company and successfully connected the TV to the new wifi. It was working perfectly until the day after, where it wouldn’t connect to the wifi. Long story short, after trying with several things like most of you, and still wasn’t working. I was about to reset my TV, when I decided to check for an update, and althought there was non available, when I went back to the screen, my Tv was now connected to the internet.

New Member

I had the EXACT same issue just now and after 4 hours of troubleshooting (2 hours on the phone with Samsung tech support, 1 hour on the phone with my Verizon FiOS ISP) I finally realized that I had used my internet parent control to block my TV thinking it was my kid's phone.  I went online and "unblocked" the device.  As soon as I did this it worked!

Oh, I also learned that if you have FiOS as an ISP do not use the 5G connection if your TV is from 2017 or earlier.  It wont work.  use the regular speed option.  Hope this helps!

New Member

its an easy fix but no on your tv, the issue is settings in windows




new problem: after the software update, the sound settings don't save as HDMI, and marantz doesn't turn on automaitically. have to go in and manually switch from TV sound to HDMI sound source.. PITA

Top Liked Authors