Open search

All 4 app stopped working on Smart TV

First Poster

I had exactly the same problem - sent an email to Channel 4 and Samsung but received no response so today I wasted almost an hour of my life on the phone to Samsung support who were very helpful but didn't solve the problem. I then phoned Channel 4 helpline to be told that there is a problem with the All4 app and Samsung TVs that they are trying very hard to resolve - they say that normally these issues are easily resolved but this time the problem is proving tricky to solve. I asked why they didn't put on their website or let Samsung know that there was a problem and she said they would investigate why that hadn't been done!!!!! She said they had no idea when it would be sorted and just to keep tryimg the app.  Rubbish service from Channel 4

Exit Smart Hub and then select Menu

Samsung TV: Model number: ue32es6800uxxu

Smarthub issue as of 5th Oct 2018.

Updated 'all4' app at prompt. All4 tv options are seen and able to select. However, the chosen programme - any programme - never loads and there is a continous four dots alternating flashing as if trying to load.

Exited Smart Hub and used Menu > Settings to access SmartHub. Then chose 'Reset'. Had to enter the pin etc and reset everything. It said firmware all up to date, etc etc. End result - no change. Restarted TV. Still no access to anything.

It sounds like some people can get access after performing a SmartHub Reset, but this does not resolve the issue for me and it sounds like I'm not alone with this issue.



Tried your idea on resetting SmartHub, but unfortunately does not work fo rme.

@Watsona wrote:

I've had the same issue, just fixed it.

menu>smarthub >reset smarthub>

then go through the process as described on screen to reset all of your apps.

you'll need your pin, which if you've not changed it since purchase will be 0000.

you'll also need to re-enter any passwords (for Netflix) etc. if you use paid for services.



I've tried re-setting the Smart Hub but All 4 app still doesn't work. The other channels seem okay. Does anyone have any other suggestions? Thanks very much.

New Member

I have the same the All 4 app updated and now wont work, have reset the Smart Hub 3 time now and still wont work.


I dont have an option to remove the All 4 App either, it will not let me remove it and re-install.


I have a slightly older modle UE46ES7000 and the All 4 App is the only one that not working since the update

Any help or ideas?


Hi Lee,


I've contacted C4 to explain the problem as I'm getting nowhere at the moment with Samsung. Will post the result of this Forum. 


Hello all


I have the same problem on 2 of the Samsungs that I have, I reset, reinstalled all the apps, checked settings etc without finding a solution.  In the end I contacted C4 over email late last week and this is the response I've had.


Thank you for your email regarding All 4.


We can advise that we are aware of this issue affecting viewers using Samsung TV's to watch All4. Our engineers are currently investigating this issue and hope to have this resolved as soon as possible.


We apologise for the disruption to your service and appreciate your patience while our team work to resolve the problem.


Kind Regards,

All 4 Support


I guess that it I will just await and update for the app.


Is anyone else still having issued with the All 4 app?


I can't see anyone on here having the same problem but for me, the app works fine, loads up a show and functions correctly until it hits the first ad break, after which the audio completely messes up, continually cutting out.


If I try to exit the show and hit "resume" the audio problem persists. This also seems to break the functionality of any other shows on the app. The only way to get the app working at all again is to power cycle the TV.


Weird that it works until ads come on, then just completley breaks.


I have got in contact with Channel 4 to see if they know anything but no response as yet.


Sorry to hear that this is continuing. After getting an email from C4 who said they had sorted out the issue with Samsung,  I deleted the service and then reinstalled the app and it seems to be okay. I'd wait to hear or re-mail C4 as they seemed to be more proactive than Samsung. Hope this works,

Top Liked Authors