Support

Open search

How to stop mobile data usage, when WiFi is connected

Highlighted
SOLVED
Apprentice

I have a new Samsung Galaxy Note 10 Plus 512GB 5G; ordered direct from Samsung UK. The handset is connected to my home WiFi and reports a "very strong" signal. However, whenever I download something e.g. a new app, the handset always uses mobile data instead of WiFi.

 

Yes, I do have "mobile data" switched on in the settings for when I cannot connect to WiFi, however, the handset should be able to prioritise WiFi when connected to WiFi and not needlessly use mobile data, but it seems that this is not happening.

 

Previously I had a Samsung Galaxy Note 4 and had no trouble with using WiFi.

 

I only have 500MB of mobile data per month, so controlling mobile data usage is critical for me.

 

Can anyone help?

2 ACCEPTED SOLUTIONS

Accepted Solutions

@ggabu500 wrote:


I cannot find anything that says "wlan" in my settings. There is a setting for mobile data which can be either set to on or off. But like I mentioned, it would be awkward to have to switch this on and off every time I am on WiFi.


https://userguide.vodafone.co.nz/samsung/galaxy-s10-android-9-0/connectivity/turn-automatic-use-of-m...

View solution in original post

Apprentice

@RolfVonHessen wrote:

@ggabu500 wrote:


I cannot find anything that says "wlan" in my settings. There is a setting for mobile data which can be either set to on or off. But like I mentioned, it would be awkward to have to switch this on and off every time I am on WiFi.


https://userguide.vodafone.co.nz/samsung/galaxy-s10-android-9-0/connectivity/turn-automatic-use-of-m...


Thank you! I guess with all the millions of settings, that was the one I missed! Now it looks like it is working. I browsed a few websites with this setting and my data usage did not go down! Thanks again.

View solution in original post

9 REPLIES 9

@ggabu500 wrote:

I have a new Samsung Galaxy Note 10 Plus 512GB 5G; ordered direct from Samsung UK. The handset is connected to my home WiFi and reports a "very strong" signal. However, whenever I download something e.g. a new app, the handset always uses mobile data instead of WiFi.

 

Yes, I do have "mobile data" switched on in the settings for when I cannot connect to WiFi, however, the handset should be able to prioritise WiFi when connected to WiFi and not needlessly use mobile data, but it seems that this is not happening.

 

Previously I had a Samsung Galaxy Note 4 and had no trouble with using WiFi.

 

I only have 500MB of mobile data per month, so controlling mobile data usage is critical for me.

 

Can anyone help?


Invoke settings > wlan, then with the 3-dot-button to the extended settings, there you can switch off the use of mobile data

Apprentice

@

 

 

 

 


@ggabu500 wrote:

@

 

 

 

 


I didn't suggest to turn mobile data off at all, I suggested to turn it off in the wlan settings. That way it isn't used if you you are connected to a wlan.

Apprentice

@RolfVonHessen wrote:

@ggabu500 wrote:

@

 

 

 

 


I didn't suggest to turn mobile data off at all, I suggested to turn it off in the wlan settings. That way it isn't used if you you are connected to a wlan.


I cannot find anything that says "wlan" in my settings. There is a setting for mobile data which can be either set to on or off. But like I mentioned, it would be awkward to have to switch this on and off every time I am on WiFi.

 

It seems the old Note 4 from 5/6 years ago was better than the newest Note 10. I thought technology was meant to improve over time not get worse.

Explorer

Turn on both WifI and Data - long press WiFi in quick settings then from there three dot menu and you will find the option to stop data while WiFi on. It's there for when WiFi is poor so the phone switches to Data to maintain good connection.


@ggabu500 wrote:


I cannot find anything that says "wlan" in my settings. There is a setting for mobile data which can be either set to on or off. But like I mentioned, it would be awkward to have to switch this on and off every time I am on WiFi.


https://userguide.vodafone.co.nz/samsung/galaxy-s10-android-9-0/connectivity/turn-automatic-use-of-m...

View solution in original post

Apprentice

@chazey2 wrote:

Turn on both WifI and Data - long press WiFi in quick settings then from there three dot menu and you will find the option to stop data while WiFi on. It's there for when WiFi is poor so the phone switches to Data to maintain good connection.


A long press on WiFi in Quick Settings (the icons at the top of the screen) takes me to the main WiFi Settings. The only 3 dots then availalbe is for Direct WiFi. I've been through Direct WiFi settings a hundred times already and there is nothing there that will prioritise WiFi over data.

 

I am 7 days into this month's data usage and already am down from 500MB to 100MB data. This is ridiculous!

Explorer

In advanced from three dot. First option 'switch to mobile data'

Is in mine.

Apprentice

@RolfVonHessen wrote:

@ggabu500 wrote:


I cannot find anything that says "wlan" in my settings. There is a setting for mobile data which can be either set to on or off. But like I mentioned, it would be awkward to have to switch this on and off every time I am on WiFi.


https://userguide.vodafone.co.nz/samsung/galaxy-s10-android-9-0/connectivity/turn-automatic-use-of-m...


Thank you! I guess with all the millions of settings, that was the one I missed! Now it looks like it is working. I browsed a few websites with this setting and my data usage did not go down! Thanks again.

View solution in original post

Top Liked Authors