Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Samsung Health snore detection not working with Watch 4 classic and Galaxy Note 10

(Topic created on: 01-09-2021 02:05 PM)
23844 Views
smbougie
Journeyman
Options

I just got a Watch 4 classic and almost everything works fine. It tracks my sleep and oxygen levels while sleeping, but the snore detection is not working. 

I have my phone plugged in and it is on a flat surface near my head. My watch knows I am sleeping, so why doesn't the snore detection work? I tried changing permissions, turned them all on for a couple nights even, but still it doesn't work. 

How close to my head does my phone need to be? Does it matter if it is a few inches lower than my head? Do I have to be facing it all night? Does the room need to be silent? Any suggestions on getting snore detection to work would be appreciated. Thanks!

 

edit: I plug in my phone and put it near my head when I sleep. I have it set to check for snoring every night. It works sometimes. One night I had tons of recordings, one night only 1, but mostly it is 0 because it doesn't work. I think it has something to do with where the phone is, how close to my head it is, because my watch/phone records my sleep just fine; if it knows I am asleep, it should be checking for snoring. 

Anyway, I am giving up on this. I know I snore and it should work and has worked, but it's unreliable. I'm just glad the oxygen levels record while sleeping, that's more important than snoring. 

59 REPLIES 59
The_Chemist
Voyager
Options

Late to the party here, but I turn sleep mode on every night and mine intermittently will record. Most of the time I get no data.  

0 Likes
The_Chemist
Voyager
Options

You are absolutely correct!  The Samsung Health app only detects snoring if you set it to once. 

If you choose always, it doesn't work!

Geez, it's May, 2022; you think they would have fixed it by now!

0 Likes
Sdrexler
Student
Options

Mine has been detecting snoring reliably all the time since 3 updates ago even when set to always detect. So make sure you have the most recent update.

0 Likes
The_Chemist
Voyager
Options

Mine just updated a few days ago, but still won't work correctly unless set to "once". I just don't get it...  This thing is so random for different owners. 

My first watch 4 was defective and I had to send it back for a replacement. The face was rotated a few degrees counterclockwise.  That watch worked reliably every night when set to always. 

Maybe it does have something to do with the watch itself and not just the app. 

Very frustrating to say the least. 

0 Likes
Siebrand
Explorer
Options

Make sure your phone is charging, otherwise it will work only once. Samsung does not want to drain your battery while you sleep...

0 Likes
The_Chemist
Voyager
Options

My phone is definitely charging and on bedtime mode when using snore detection. 

I have to charge the phone every night. It is a brand new S22 Ultra. The battery life is horrible as compared to my S21 Ultra that I traded in on Samsung.com. 

0 Likes
Sharonmancini29
First Poster
Options
Mine works but it has a strange background noise when you listen back. You can also hear my cat meowing and my husband getting up for lol. I sound horrendous 😭 😕 😩 you seam to be doing it right. I also wished you could share the recordings with you GP as well especially of your having sleep apnea tests. Good luck in getting it to work.
0 Likes
K3v7ar
Explorer
Options
😁
0 Likes
sigdiff
First Poster
Options

You should b able to make this choice yourself.  I do not use the alarm on my phone.  I don't care if the battery dies overnight.  I care about leaving my phone on the charger for hours at a time when it only needs 30 minutes to charge.  This is bad for the battery.

0 Likes
AwakenedCloud
First Poster
Options

Hello, chiming in from 2024 but I think this is still the case.

 

I got my Galaxy 4 watch about two weeks ago and at some point decided to try the snore detection on a whim. I said it to one time only and found out that I snored for at least 2 hours the night before. I became curious about it and set it to "always on". Ever since then, it hasn't recorded anything for snoring. At first, I thought it might just have been a one night fluke where I did snore, but it didn't make any sense that my snoring just casually solved itself.

I'm going to switch it back to "one time only" and see if I get results.

 

Edit: As suspected, setting it to one time worked. For the first time in 2 weeks, I had snoring activity and I really doubt it was just a coincidence. Even weirder, when I went back into advanced settings snore detection was still on. The description under the setting says that if it's set to "one time", it will turn itself off after it happens. The entire process seems bugged.

0 Likes