Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

MyFitnessPal and Samsung Health not connecting any longer (steps)

(Topic created on: 30-08-2019 04:03 PM)
twizlan
Apprentice
Options
Wearables

Hello, anyone having this issue?

 

As of today I noticed that my steps from my Galaxy Watch Active, recording in Samsung Health, were not being synced to MyFitnessPal.

 

In the settings for Samsung Health, it no longer offers me the options for allowing read/write access for each data item, it just has 1 toggle "all permissions". 

 

In the Apps Connected area of MyFitnessPal, it now just says "connect" under Samsung Health, I click on it, it opens a little menu with 1 item of data "all permissions". 

 

It seems as though the actual permissions have been broken with the last update.

 

I have tried the following:

- Clear cache on both, then restarted.

- Reinstall both apps fresh.

 

I am now at the end of the road, I think it could be the latest update causing issue, which was 2 days ago (For Samsung Health).

 

Reading the reviews on the Galaxy App Store it looks like multiple other people are having this issue since the last update.

 

Just trying to raise visibility.

T

 

Edit: A workaround has been identified that seems to be working! Credit to the below. 

 

@Gisbourne wrote:
Hi all,


Find this workaround while browsing the MyFitnessPal forums which seems to be working...

megapsyk
Aug 30, 2019 01:20PM PDT

I found this comment on a Google Play app called 'Health Sync:

Samsung Health missing permissionsSamsung withdrew accidentally all permissions for Health Sync on August 30, 2019. We are in contact with Samsung to fix this. Temporarily you can use the special developers mode in Samsung Health as workaround. This doesn't do any harm. Open Samsung Health, go to the Settings menu, choose 'About Samsung Health' and tap the version number ten times in a row.'

I tried this and I can sync now. Either they fixed the issue or the developers mode worked.

Good luck 😊

 

 

53 REPLIES 53
mattman73
Journeyman
Options
Wearables

Sorry to hear you are facing the same issue, I have got my working again but to be honest I have no idea how I got it working as I tried so many different steps, just keep removing both apps and clearing cache on both apps then install.

I'm still having issue around when the app is passed exercise other that steps it will do something very strange in that it will do calorie adjustment and add the other exercise but remove the step count and calorie count.

Really not sure who is at fault with all the issue but all you will get is Samsung will say it is my fitness pal fault and my fitness pal will say it is Samsung fault.

If I could find a different app to use that I would change I have looked but as yet I have not found anything that I like. 

All the best for 2021

Matt

0 Likes
Vinnayar
First Poster
Options
Wearables

For those who are still having issues with syncing, there's another step you have to do after enabling the developer mode. You click on set features, fitness, then under exercise tracker sync mode select all (fitness/running program/exercise). When you back out of samsung health it'll have you force stop the program and it should sync properly. 

0 Likes
samthehuman
First Poster
Options
Wearables
change your units of measurement for distance in the Samsung health app to mi,ft and it will sync to MFP, worked for me
0 Likes
chaachy
First Poster
Options
Wearables
Incredible, this looked so unlikely that it would work. I was at the end of my tether, tried this as a last resort and it worked!! Thank you megapsyk!
0 Likes