What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

Original topic:

Map My Run Elliptical Training Doesn't Start on Active Watch

(Topic created on: 05-03-2020 03:44 PM)
First Poster

Hi, wonder if anyone can help.  Been using my active watch to track my workouts - both running and elliptical training using the Samsung Health app.

I track all workouts in Map My Run, which syncs with Samsung Health - although, if I use Samsung Health on the watch, it keeps duplicating the workouts in Map My Run.  Is there any way to stop this?

I've worked out that maybe I should use the Map My Run app on the watch to track runs instead (haven't tried it yet though).

The other main issue is that I use my elliptical trainer almost everyday, but when trying to use Map My Run on the watch to track this, I can't get it to actually start the workout - the start/play button appears, but pressing the button on the side, nothing happens - no matter what I try, it doesn't start - can anyone advise???  I can obviously keep using Samsung Health for this, but Im then left with the above issue of duplicate workouts in Map My Run!