Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

How do I change language from Chinese on my new Galaxy 6 classic when I can't read the menus?

(Topic created on: 27-12-2023 10:18 AM)
904 Views
Lordwanswell
Journeyman
Options

How do I change language from Chinese on my new Galaxy 6 classic when I can't read the menus? I can't connect to my phone either. 

0 Likes
4 REPLIES 4
Juledrop10
Apprentice
Options
I'm having the same issue with my Galaxy 6 watch. The watch menu is in chinese and the phone tells me to go into settings on the watch to connect which I can't. I can't find any videos to help with this either
0 Likes
Solution
Lordwanswell
Journeyman
Options

I have now solved this, based on advice I saw elsewhere to use Google Translate in problems such as this. You can translate the Chinese text on the fly by opening GT on your phone and with the camera pointed at your watch face you will see the English translation of whatever is on it. Using this, I established that there did not seem to be any way of changing language from the settings menu. I had read somewhere else that you are given this as a choice when you first turn on the watch, but I obviously missed that as it was in Chinese. It doesnt seem to appear when you just switch off and back on. So, the only option is to "reset" which is the final option under the Settings - General menu. When you do this, the watch completely reboots and you get the opening screen, after it says "Welcome", which gives you about three options, the first of which is "language". Press this and you get the full list and you can can change to English, or any other language. Once I had done that, it seemed straightforward to connect to my phone. I could not have done this without Google Translate, which is amazing. I hope this helps you Juledrop and anyone else who is struggling.

Juledrop10
Apprentice
Options
Thanks! I managed to reset the watch and all OK. now I can enjoy using my new device. ☺️
Lordwanswell
Journeyman
Options

That's great, I am glad you made it work!

0 Likes