Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Gear S3 can't connect after Oreo update

(Topic created on: 26/04/18 12:12)
MilosDjuk
Apprentice
Options
Wearables

Hi everybody,

 

after Oreo update (few weeks ago) I couldn't update any galaxy apps and Gear S3 got disconnected from phone. 

Today I got new Android update with which update problem of galaxy apps is fixed but connecting Gear is still not working...

I tried with clearing the cash from whole phone, from Gear app, deleting BT profile, installing Gear app from play store and galaxy apps...

Phone and watch get paired, percentage count get to 100%  but phone stays forever on screen "setting up your phone..." and "almost there" is just blinking...

 

Phone Details:

Samsung Galaxy S8

Model No: SM-G950F

Android Version: 8.0.0

Samsung Experience Version: 9.0

 

Gear S3 Details:

Samsung Gear S3 Frontier 

Model No: SM-R760

Tizen Version: 3.0.0.2

 

any idea how to fix it?

thanks

 

Go to solution
24 REPLIES 24
mwstew21
First Poster
Options
Wearables

I am having the exact same issue with my s8 and Gear S3 watch, ICONX-2018. I talked to Samsung support and they confirmed the latest OREO updated has caused this issue but no schedule to fix it.

They suggested I go to Bestbuy and have the flash my software to previous version. OUCH>>>>>>>

0 Likes
Reply
MilosDjuk
Apprentice
Options
Wearables

or try to do factory reset of phone and watch, this works for me but it takes lot of time and to do backup of all your settings/apps... and to do this every single time there is new version of gear app or gear software... quite annoying 

I'm doubting that in my case problem lies in some security conflicts as I have also company account on phone...

0 Likes
Reply
SammyBabby
Observer
Options
Wearables

I have the same problem. I try rebooting the watch and phone, I try deleting the Android Wear and reinstalling it. Nothing Works.

0 Likes
Reply
Saif26
Observer
Options
Wearables

Hi,

I'm facing the same issue. Based in the UAE. 

 

Error reports sent via the Members app.

 

Thanks!

0 Likes
Reply
VFRBOY
New Member
Options
Wearables

Having the same problem here. New phone, Oreo, same Gear S3. Works perfectly with the old phone.

With Oreo it works once after a factory reset on the S3, then fails to reconnect once Bluetooth goes out of range.

Very disappointing, hopefully there's a solution. 

0 Likes
Reply