Open search

Gear S3 can't connect after Oreo update


Hi everybody,


after Oreo update (few weeks ago) I couldn't update any galaxy apps and Gear S3 got disconnected from phone. 

Today I got new Android update with which update problem of galaxy apps is fixed but connecting Gear is still not working...

I tried with clearing the cash from whole phone, from Gear app, deleting BT profile, installing Gear app from play store and galaxy apps...

Phone and watch get paired, percentage count get to 100%  but phone stays forever on screen "setting up your phone..." and "almost there" is just blinking...


Phone Details:

Samsung Galaxy S8

Model No: SM-G950F

Android Version: 8.0.0

Samsung Experience Version: 9.0


Gear S3 Details:

Samsung Gear S3 Frontier 

Model No: SM-R760

Tizen Version:


any idea how to fix it?




Accepted Solutions



Thanks for sending over the Error Report, it helped us resolve the issue. The response we received was that there was a temporary server issue when your device was trying to register. The problem was with the Gear app itself which has been fixed server side, hence it now working for you.


A simple restart of both devices will solve the problem if this occurs for anyone else within the UK. 

View solution in original post

New Member



The same thing happens to me.


I am Japanese and I just recently updated to Oreo.


I contacted customer service in Japan, it is under investigation.

The same issue with Samsung Galaxy s7 updated to Oreo. I can't pair the phone with my Gear S3 frontier


Tel: SM-930F

Android 8.0.0

Ver: R16NW.G930FXXU2ERD5


@MilosDjuk@andre-20 Looks like you've tried the suggested troubleshooting, so the next step would be sending an Error Report onto us via the Samsung Members app. We will then be able to analyse this and provide feedback.


Replicate the issue > open Samsung Members app > select Support > Send Feedback > Error Reports > Application > tick Send System Log Data, and attach a description of the problem. Make sure you complete this process within 15 minutes of the issue occurring - preferably quicker if possible.


Can you also include your Community usernames (eg: LiamH) within the message content? One of the moderators on here can search for your Error Report and speed up the process.


@jojonao172570, we'd love to help out with this, but we can only search for UK Error Reports from here. The best course of action would be to chase this up with your local Support Team. 

thanks @LiamH error feedback sent

@andre-20 Cheers, I've found that. I'll pass the Error Report on internally. You'll get a response via the Samsung Members app once it's been looked into. I'll follow this up and update you all.



@LiamH, feedback log just sent out

Hi @MilosDjuk


Haven't been able to locate that. Can you please try again when you've got chance, making sure you include 'MilosDjuk' in the message content? I'll be able to search for that and pass it on for you. 



just did it again, in both send-outs I mentioned my username, screnshoot attachedScreenshot_20180503-125701_Samsung Members.jpg

Thanks for confirming @MilosDjuk


Are you currently within the UK, and which country does the phone originate from? Having a little trouble locating this, and think the routing of the Error Report is the issue.


Top Liked Authors