Open search

Galaxy Watch Stops Recording work out part way through


So this is really annoying now.  For months the watch has been fine but a couple of weeks ago now I got half way through a run and the watch stopped recording.  I use the watches work out app, select running (basic work out) and press start.  It records for about 10 minutes and then stops.   So a couple of days ago I set the screen to stary on during the run and it was fine for one run.  I ran again today and again it stoped after about 2km; no record of the run at all.  Any help would be greatly appreciated.

188 REPLIES 188
First Poster

Same problem appeared to my Active 2 after the last update in October 2020. It stops tracking my circuit training at the gym and it's super infuriating. Location - Moldova / Eastern Europe. Please fix it ASAP Samsung. SmartSelect_20201107-205443_Samsung Health.jpg

New Member
I had the same issue today on my ride, after 8km my watch stopped recording any data. How am I suppose to keep track of my progress etc when the majority of my workout isn't being tracked.

Today I disabled Bluetooth on my watch, leaving only audio connected. It worked. Circuit training didn't stop. Nevertheless I find this as a temporary solution until the issue is fixed. 

SmartSelect_20201108-214156_Samsung Health.jpg

First Poster

I've just started having the same issue with walking and running. Sometimes it literally cuts out after a few seconds, other times it lasts an hour or so before cutting out. It's so infuriating. I even tried downloading the strava app and recording a walk on that directly and it cut out within seconds of starting to record.

First Poster

I have also noticed this problem in the past few weeks. I have tried walking, hiking and general exercise and all those stops after few seconds or minutes. Super, super annoying.  I think this started after the update on my galaxy S10 phone a bit over two weeks ago. I have a galaxy watch 42mm.

Please Samsung fix this ASAP!

This has happened to me today, am not impressed at all. How can Samsung not have sent any update on this at all? I've just done a workout and to my dismay it was not recorded on my watch. Any exercise I try now it cuts off after a few seconds. Please sort this out ASAP!

First Poster

Have any of you, who has this problem, had also problems with the sleeping mode (in my language it is called "good night" -mode)? I can turn it on, and it stays on, but it doesn't "lock" the screen at all. The screen looks normal, not the usual black mode with only some information in blue. It also doesn't show the little symbol at the bottom of the screen, when the mode is on and screen looks like the normal clock. It makes me leave the sleeping mode accidentally on, since I don't get the information about it being on only by looking at the normal clock screen. 

I tried today disconnecting the watch (bt-connection) from the phone while on my walk, and it didn't help at all. The walking exercise stopped after 3:38. Frustrating.

I don't think Samsung are monitoring this thread, people would be better served raising complaints or customer service requests with Samsung themselves.

New Member

Try doing a hard reset on your watch

First Poster

It's so frustrating. I tried the hard reset two times now. Still it stops recording a while later. Now I am at the point, that I'll try an apple watch.

Top Liked Authors