Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Wimbledon iPlayer UHD red saturation

(Topic created on: 30-06-2022 08:22 PM)
Techpassesmeby
Apprentice
Options
TV

I have a Samsung  QN95A and I am watching Wimbledon in UHD on the BBC iPlayer app. The red level is waaaaaaay too high. Everyone looks like they have terrible sunburn. 

Help please....how can i fix this?

0 Likes
7 REPLIES 7
AndrewL
Moderator
Moderator
Options
TV

@Techpassesmeby: Please try heading to Home > Settings > Picture > Expert Settings, and adjusting Tint (G/R),  RGB Only Mode and Colour Space Settings to your preference. Let me know how you get on. 

JAMES4578
Samsung Maker ★
Options
TV

Hi @Techpassesmeby  Just to add to to the beneficial  advice @AndrewL  provided  presumably video is set to best quality .   You might also want to have a look at contrast Enhancer and colour Tone and can adjust the HLG.

Some information for those who may be interested in the Wimbledon UHD service https://www.cordbusters.co.uk/bbc-wimbledon-2022-4k-ultra-hd/ 

It seems to have been fine for me though I am watching  Jack Draper on court 1 at the moment,UHD only available for centre court.  one thing to bear in mind is that the streams are slightly behind  the live play.

 

 

I do not work for Samsung or make Samsung Products but provide independent advice and valuable contributions.


My Device- S21 Ultra 5G ( SM-998B/DS ) CSC= BTU , 12GB/256GB
One Ui 4.0,Android 12 Official Version.

Techpassesmeby
Apprentice
Options
TV

By changing the Tint (G/R) i can dial out most of the red but thrn the green becomes the problem. Especially so give Wimbledon is on grass courts that now look radioactive.

Jay90
First Poster
Options
TV

I had the same - colour saturation too high. Changed Colour Space from Natural to Auto.  Fixed it. 

JAMES4578
Samsung Maker ★
Options
TV

@Techpassesmeby  is RGB  Mode definitely switched off ?   In colour space settings see if Auto makes a difference if on Native.  If still issue also try and custom setting for all the different colours. see some information here  https://www.samsung.com/my/support/tv-audio-video/what-is-the-color-space-setting/  https://www.lifewire.com/best-picture-settings-for-samsung-4k-tv-4776573 

I do not work for Samsung or make Samsung Products but provide independent advice and valuable contributions.


My Device- S21 Ultra 5G ( SM-998B/DS ) CSC= BTU , 12GB/256GB
One Ui 4.0,Android 12 Official Version.

0 Likes
Techpassesmeby
Apprentice
Options
TV

It's set to Native but it's greyed out. Any ideas how to enable the setting so i can change to Auto please?

0 Likes
Jay90
First Poster
Options
TV

Sorry, I don’t know. I assume one of the other picture settings is disabling auto. Film mode is greyed out on my TV but if enabled on yours, might be a first thing to try. Otherwise, see if the other picture settings are greying out the auto. RGB is off on my tv fyi. 

0 Likes