Open search

Stuck at smart hub being updated




My TV’s model code is UA40J5200


last night i reset smart hub and since then I receive the above message “ your smart hub is being updated, please try again later”.


I checked today morning to find it the same. I then tried to do EEPROM reset but the TV didn’t restart twice on its own as I was expecting so I guess the EEPROM reset for this model has different procedures.


Should it restart twice after I press the power button on the remote controller for 3 seconds and release it ? 


Here’s what I did 

1- press and hold physical power button (tv turned off)

2- within 10 seconds from step 1, press and hold remote controller power button for 3 seconds (tv starts again) 


Any help would be appreciated


Hi @Amaksoud 


Are you still receiving the message 'your Smart Hub is being updated'?

Hi @ChrisM


Yes, I’m still getting it

Could you check that all the T&C's have been accepted (ticked)? Go to Menu > Smart Hub > Terms & Policy.

Smart hub T&C & smart hub privacy policy don’t show any options except for scrolling down the screen, I think they are OK.


online remote management service T&C were not ticked (I didn’t activate remote management anyways) but I ticket it and still got the same issue

Help is still needed please.


Same problem but on a UE40F5505AKXXE.

Any help appreciated /Björn



My Issue was resolved.


What I did was to open smart hub, click on applications and click on one of the apps that was not starting from smart hub home screen and surprisingly it opened normally.


Try that, it may help you. Also check that you have agreed to all licnese checkboxes (3 in my case, 2 were selected and the third was not)



Thanks for the input.

I believe my issue started when I upgraded to sw 2126 from an ancient version a few weeks ago. Every now and then I was stuck on "smart hub being updated" when trying to access smart hub functions.

I tried to follow your recommendation wrt licenses. Unclear if it worked. The UI to the smart hub is really not great.



The behavior is now

1) first 45s after power-on: The TV says "smart hub is updating" (but in Swedish)

2) after 45s the Smart hub works


I *believe* this behavior is triggered by me updating the TV to version 2126 some weeks ago.

I would *guess* it is some kind of race where some parts of the firmware wait on something to happen that takes about 45s to happen.

The behaviour is robust, that is same behaviour every time => really annoying!


Some ideas are most welcome!!


Top Liked Authors