What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

Samsung Q60 TV Red Flickering Power LED/Flashing Black Display

(Topic created on: 21-02-2024 09:15 PM)
First Poster

Have had this TV for about 4 years and started getting some lines through the screen a couple months ago. It would start going through these power cycles with no display every now and then. Now it's starting to become permanent. Right now me and my Fiance can't watch TV since this had been going on ever since we got home hours ago. The TV will play sounds for half a second at times, screen goes from Grey to black with no picture ever showing followed with a red periodically flashing light.

Here are the things I've tried so far:

- Power cycled the TV unplugged, power button held for 30-40 seconds then plugged back in.

- Reset living room outlets with fuse box.

- Switched power from power brick to direct outlet.

- Held down every button on the TV and remote, reseated all cables including HDMI.

- Took batteries out of remotes and only used power button on the TV.

- Changed power cord to known-good power cable. 

- Resetted cable box.

I've done all of these with no luck. I do have 2 remotes connected to the TV but I took the batteries out so those remotes are ruled out for being the iissue. The keep hearing the TV turn on but it never shows the picture. I know this is a common problem with Q60's alike but money is tight right now and me and my Fiance really CANNOT afford to break the bank going to get it repaired or replaced. Let me know what to do, what I haven't done yet, please. Thank you.


Edit: I took the TV apart trying to find the solution. I realized when I disconnect the left panel ribbon cable, it will display image, sound and won't shut down. Now the picture color is inverted. Everything is blue, green and white. Most of it looks white but I've tried using tape on the left panel cable pins but no luck. Can anyone tell me how to get the picture color back to normal?

Steve Carroll
First Poster


I have the same problem did you get a fix