Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Regarding firmware update 1520 for Q90B TV Problems with 60hz @ 1440P PC mode (EDITED/UPDATED)

(Topic created on: 30-08-2023 11:47 PM)
2078 Views
nalfylatino
Explorer
Options

Hi,

I will rewrite this post now that I am on my computer. At some stage my QN90B TV updated to the latest 1520 firmware (I never realised though it did coincide with the dimming coming back). I have a PC with a NVIDIA RTX 4090, I9 13900K CPU, everything is up to date including Windows 11. 

Prior to this firmware update, I had no problems playing games on my system at 2560x1440 at 60hz. I set the refresh rate on the Windows desktop at 60hz, and going into the game I would get 60hz/60fps locked and with vsync everything was pretty smooth. Fast forward to now, and going into the same game (I have also tried this with other games, same problem) it seems that even setting the refresh rate to 60hz in windows and playing the game at 1440p results in jerky/teary movement when playing games. Vsync doesn't make a difference. It almost feels like the games are ignoring the 60hz refreshrate set in Windows, bypassing it and auto setting itself to 120hz or around there. This is new behaviour with this firmware update, and did not happen previously. I have even reset the television and tried different nvidia drivers to see if it makes any difference to no avail.

The only temporary solution I have to this problem is setting a custom resolution of 1439p through regedit and then using that along with 60hz and everything is smooth again. I hope this gets looked at as one of the reasons I bought this TV was because of its 1440p 60hz support. It seems that it is broken, at least with a PC using Windows 11. I would also like to note that this issue is not prevalent using any other resolution. Just 1440p.

2 REPLIES 2
nalfylatino
Explorer
Options

I updated the post

0 Likes
ALEX_CLE
Navigator
Options

Try changing the type of the hdmi source from PC to Home theater. Then everything works great.

0 Likes