Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Q80AA 55 ..ITV X, C4 AND MY5 APPS WON'T PLAY

(Topic created on: 12-10-2023 06:10 PM)
466 Views
TvMan1001
Apprentice
Options
Q80AA 55 TV bought in 2021

Fault

Can't access app ITV X , page sticks at title screen and locks.

Channel 4 app , menu loads,  might play an advert to start,  but program won't start

My 5 app, menu loads but won't play any program


Action taken

Soft reset by holding power button
Unplug tv
Reset router
Reinstall apps
Reset smart hub
Manually entered a different DNS before returning to auto setting

Spoke to Samsung support where they took remote access to tv, performed a reset in engineers mode

They have said the fault lies with ITV X and to contact them,  which I will do

And  they say the  C4.and My 5 issue is because of a slow internet speed which is absolutely not the case.  All other streaming apps perform flawlessly,  indeed so does C4 and My 5 on my PS4 in the same room. It is Itvx I particularly  want working again as it is not available for ps4.

Any one else experiencing these issues? Any suggestions before I contact ITVX technical. 

Thanks
0 Likes
2 REPLIES 2
TvMan1001
Apprentice
Options
I think I am near to solving this issue, so I will return and submit my findings when done but in the meantime I have discovered that by tethering my phone and using it as wi fi hot spot it instantly resolves the issues.

Channel 4 , My 5 and ITV X load and play seamlessly.

For your information I have fibre internet connection at 950mps up and down , Truespeed provider, Zyxel router, Samsung tv connected via wi fi with at least 180mps in that room. I tried both the 2.5ghz and 5ghz bands.

It seems there is something on the router end that is causing this problem only on those 3 apps. BBC, YouTube , Prime etc all ok.

I note that technical support told me that the network was dropping a lot when those apps were trying to play that didn't make sense, however I have seen other posts where the complaints seem to show a drop and buffering on previously solid performances.
0 Likes
TvMan1001
Apprentice
Options
I'm pleased to report this issue has now been solved by a router firmware update (however as a separate issue the router performance is not good now and will be changed).
0 Likes