Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

HDCP Errors on 2016 TV

(Topic created on: 04-06-2022 07:57 PM)
floyd86uk
First Poster
Options
TV

Hi there, 

I have a 55 inch TV purchased in 2016 (UE55KU6500UXXU) and I've started getting HDCP errors when trying to watch Netflix or other copyright-protected content like Amazon or Disney+ on my streaming devices.

I have both a new Nvidia Shield TV and old Amazon Fire TV Stick. I bought the Shield to replace the Fire Stick, as I thought it was a problem with the Amazon device.

It seems that after an hour or so of being idle, I can no longer see the Fire Stick menu and just have a black screen. If I cut the power to the Fire Stick and power it up, the 'Fire TV' logo appears, but then cuts to a black screen again after a few seconds. With the Nvidia Shield, I can access the menu all of the time, but I get an 'HDCP Error' when trying to watch Netflix.

If I cut the power to the TV from the wall and then power it up again, I can then access the Fire Stick menu and watch Netflix on the Nvidia Shield. It seems that the problem starts when the TV is idle and wakes up. After this time, I can no longer access the Fire TV menu, or watch Netflix on the Nvidia Shield without needing to power cycle the TV.

I have tried 4 HDCP 2.2 compatible HDMI cables, but have the same problem.

I have tried both devices on other TV's and they work just fine.

I have also tried both devices with this TV, but connected via an AV receiver. This worked without issue too, so I'm assuming that was probably bypassing HDCP (?)

This definitely seems to be a problem now with the TV and I'm not sure what to try next. I can't use the AV receiver any longer and need to use these devices directly connected. Has anyone else started to have this issue and if so, any advice on how to get around it? It seems like a really difficult issue to try and prove to a repairer, but it definitely seems to be related to this TV and HDCP.

Thanks 

0 Likes
4 REPLIES 4
Pugs1957
Samsung Maker ★
Options
TV
What happens if you reboot the TV? I'm starting to think that on wake up the handshake isn't being implemented. Did you let the other TVs sleep when you tested them?
antikythera
Black Belt 
Options
TV
As daft as it may sound in 2022 given it's 6 years old, check on the Samsung website for any firmware downloads for the TV just in case they didn't get remotely installed as OTA via Freeview or internet if it's a Smart TV. You can flash updates from a USB pen drive in such instances
JAMES4578
Samsung Maker ★
Options
TV

Tv updates can  at times be firstly be available via USB downloads, the latest firmware though is 1250.2 which was released October 2021. Check if you have this @floyd86uk  Upgrade final shown in this link https://www.samsung.com/uk/support/model/UE55KU6500UXXU/ 

I do not work for Samsung or make Samsung Products but provide independent advice and valuable contributions.


My Device- S21 Ultra 5G ( SM-998B/DS ) CSC= BTU , 12GB/256GB
One Ui 4.0,Android 12 Official Version.

antikythera
Black Belt 
Options
TV
I'll bet that contains the necessary DRM updates. USB is the only I could update mine as we don't have Freeview and it's not a smart TV. I just checked it again and it has the latest firmware from 2016 according to the website. It's an old EU32J5100 that to be fair still works flawlessly.