Open search

BBC iPlayer Not Loading Error 02001

First Poster

Hi. For 2+ months now I've been unable to load programmes in BBC iPlayer app on my new Samsung UE49MU7070 TV, 2017 model. All menus load fine but every programme I choose has continous spinning circle and after 30 seconds always ends with cannot load error message 02001. I have tried every reset possible and all firmware/software is right up to date, have tweaked most tv settings, searched the internet for a solution, and have got nowhere with iPlayer and Samsung support. All other on demand TV and Netflix, Amazon etc works fine and internet connection is the best. There was a couple of weeks after purchase when iPlayer worked ok but not anymore and I don't know what's changed. I am at a loss, can anyone help please, I can't be the only one with this problem? Thanks.

108 REPLIES 108
Samsung have, so far, only released firmware version 1210 publicly on the internet - I just checked the download page for my TV.
Software Version 1230 must still be undergoing internal testing but can clearly be posted out to customers if they encounter BBC Iplayer Error 02001; again, at least for my TV model.
Thanks for this. Any chance you could zip up the update and post it somewhere for us to download?
I don't want to be responsible for a whole load of broken TVs though :winking-face: I've no idea whether the firmware is specific to my exact model or not (It's a 1.25GB data file). There's probably a reason why Samsung haven't yet officially published it, so it's probably best to push them to send the USB out to you. I imagine it could invalidate your warranty if you start updating with firmware off the internet without their prior approval.

I think that's a really good point - guess it's best to just wait for the USB stick from Samsung, for specific models of TV, or the auto-update.


On a seperate note - just had 2 hours on the online chat, and it was a complete waste of time! What a depressing experience. I love my TV, but more than a little disappointed with Samsung support.


Understood. I wouldn't hold you responsable. It's just that I'm not in the UK and Samsung won't provide support for a UK app not working abroad. Thanks anyway.


I contacted Samsung again today as I would really like to watch the 4K footy. BBC iplayer and my5 hasn't worked since last November.


Samsung Support are sending me a USB with new firmware which they say fixes the issue.


However, I updated to firmware version 1230 which was shown as available on their website as of yesterday. It hasn't fixed the issue.


I hope the USB firmware is recognised by my TV if it has the same number. Will let you know how I get on.


Have the same issue. Really bad timing for world Cup!


Samsung not really helping me out due to me buying TV second hand. 


I have installed the 1230 firmware which is now on the website but this did not fix the issue for me. If anyone who has recieved the firmware direct from Samsung on a stick would be willing to upload or send me I would be eternally grateful. 


Well, I didn't get my USB stick. So I contacted Samsung. The firmware 1230.0 which was thought would fix this issue didn't. Support tried for an hour to reset the TV and check the internal settings, but finally admitted defeat. again they have esculated the issue to their engineers, but I don't hold out much hope that this QLED TV will ever be able to get iplayer and My5 apps working. 

I have another issue where the backlight is periodically flashing like a strobe light on the right 6" of the screen. When this happens with LED house lamps, it is usually a sign the electronics that control the LED are on the way out.


I won't be buying Samsung again.



I have same issue with UE49MU6500. It has been going on for six weeks. Have contacted Samsung 5 times and been told 3 times a USB is on its way. Nothing. I have updated to 1230.0 and tried every form of reset/reboot suggested anywhere. Nothing. I am now going to return television to John Lewis as it has 4.5 years left on its warranty. What a waste of time this has been. Samsung service is a joke. Wont be buying again.

Hi all dont know if anyone has noticed but firmware 1230 has been pulled and been replaced with a 1221.0 so all us who updated to 1230 CANNOT upgrade the firmware anymore as that number is obviously less than 1230 (which did not fix anything on my UE40MU6400) so thanks for putting out another firmware but why put out one with a number less then the one that went before it ??
Top Liked Authors