Open search

BBC iPlayer Not Loading Error 02001

First Poster

Hi. For 2+ months now I've been unable to load programmes in BBC iPlayer app on my new Samsung UE49MU7070 TV, 2017 model. All menus load fine but every programme I choose has continous spinning circle and after 30 seconds always ends with cannot load error message 02001. I have tried every reset possible and all firmware/software is right up to date, have tweaked most tv settings, searched the internet for a solution, and have got nowhere with iPlayer and Samsung support. All other on demand TV and Netflix, Amazon etc works fine and internet connection is the best. There was a couple of weeks after purchase when iPlayer worked ok but not anymore and I don't know what's changed. I am at a loss, can anyone help please, I can't be the only one with this problem? Thanks.


Accepted Solutions

:smileyvery-happy: So I got our TV fixed today and access to iPlayer restored :smileyvery-happy:


The issue is a virus in the app that damages the motherboard and only resolution is to have the motherboard replaced.  


I suggest anyone still having a problem call Samsumg customer support asap.  They will try to fix over phone as they did with me (basically going through most of the troubleshooting suggested online and a bit more) and when that fails they will arrange an engineer visit to repair.  

Pretty good customer service from Samsung -  enginner visit arranged quickly and repair only took about 15/20 mins.  I just wished I had contacted them earlier and not paid heed to the BBC message which led me to believe the issue would be resolved.


Engineer said that cause of the problem only identified in last week or so.


ps allow around an hour for the call to Samsung customer support in the first instance!

View solution in original post

108 REPLIES 108



You are not the only one - I have the same problem with my UE55MU6500. Have you tried the other BBC apps like News and Sport, I can read text news stories but any film clip gives the same error. Also My5 gives an error message when I try to play a programme.


I found a page that listed all the Samsung TVs that were certified to work with iPlayer and it stopped at 2016. I have been told that the 2017 TVs have now beeen certified.


My version of the iPlayer app is 1.1.3 and unusually it doesn't allow me to Sign in which I thought was necessary these days with the BBC. I am currently on my second support call and have just got through the technical tests, though I haven't logged back in to all my apps just yet as it takes a while. I am on firmware 1151.1.


Lets hope they find a fix soon.


Is there anybody whose 2017 TV does play programmes through iPlayer?



It is usually a temporary error that number however it could be cause by all manner of things.  It might be you have been given a new IP address from your ISP which is recycled and doesn't show up in the UK and so is blocked.


Try this website and see which country it thinks your IP address is in to rule this in or out





Same boat as all of you, 2017 build and it worked fine for about a month when the TV was new, now I just get the Error 02001 message. I did however get the login page today which gave me hope it would start working. Guess what logged in, and still get the 02001 Error.


Please Samsung work with BBC to sort this out, don’t leave it to your consumers.

I too can now log in to get the error message, haven't had chance to reset anything to test further, will try later.


Small steps...

Any luck?? I have tried a factory reset and nothing 😞

‘fraid not. I tried changing settings around and the version to Beta and the video to SD.

Glad you tried the reset, it means I don't have to re-enter all my passwords!


Have you tried asking support to log in and test the TV? I have had two calls logged but been out when they called back.



I have tried once but like you have been out when they called 4 days later.


Will try again... Will keep you posted

Hi MU fans.


In case you haven't noticed  as of 27th December 2017 there is a new USB release of firmware 1155.1

however as the text in the link still says "Upgrade File(USB type) ver 1151.1, All Windows (MULTI LANGUAGE)"

it is hard to spot. However the date against the link is "27 Dec, 2017"


Luckily I have a program checking for changes to the page or I might have missed it. 😉


Unluckily it doesn't seem to have fixed the 02001 Error with iPlayer.


Happy Holidays and a Happier New Year to you all.



I too have this problem on my Q7F QLED TV. iplayer and My5 not showing any video.


I contacted iplayer and they have now posted this message on their website:

I contacted Samsung support who took control of my TV, reset apps but that didn't work. I was told that Sansung are aware of it and it would be fixed in the next firmware update.  However, a newer firmware was released on 27th Dec but that didn't fix the issue.

My family are not too happy that they couldn't watch iplayer over the Christmas holiday - thanks Samsung.


Looks like my Smart TV isn't so Smart after all 😞

Top Liked Authors