Open search

BBC iPlayer Not Loading Error 02001

First Poster

Hi. For 2+ months now I've been unable to load programmes in BBC iPlayer app on my new Samsung UE49MU7070 TV, 2017 model. All menus load fine but every programme I choose has continous spinning circle and after 30 seconds always ends with cannot load error message 02001. I have tried every reset possible and all firmware/software is right up to date, have tweaked most tv settings, searched the internet for a solution, and have got nowhere with iPlayer and Samsung support. All other on demand TV and Netflix, Amazon etc works fine and internet connection is the best. There was a couple of weeks after purchase when iPlayer worked ok but not anymore and I don't know what's changed. I am at a loss, can anyone help please, I can't be the only one with this problem? Thanks.

108 REPLIES 108

Hi, I have been in touch with Samsung via email last night and today (got to be said quick response to two emails that I sent during the working day so fair play on that matter) they have offered to send out the as of yet unreleased 1239.0 firmware to hopefully fix the problems that the TV is experiencing, no iPlayer, NowTV or My5 when that arrives I will give an update to hopefully say all is fixed. So, if anyone else still has not been in touch with Samsung on this matter emailing their support department might be easier than going through an hour of "live chat" or racking up a phone bill to get to the same outcome,

Cheers all,


Samsung Support sending me firmware 1239.0 on USB. 5-7 working days. Previous USB didn't arrive. Why can't they provide a link for affected customers to download this firmware instead of sending USBs 😞

First Poster

Problem occurred here 2 days ago on my UE55MU7000 purchased early this year. Chat support acknowledged the problem, didn't ask me to do any tests or try any fixes - just asked for details of TV and my address to send USB firmware. 

Annoying that the new firmware isn't available to be sent via email or download from a restricted site (assuming they have good reasons for not making it public yet) but all I can do now is wait and see when the USB arrives in (hopefully) a few days.


Now, where did I put that Chromecast?

HI all, Just an update regarding the magical USB firmware to fixx all our TV's, I have just received mine un todays mail ran the update and, well NOTHING !!! just as useless as before, so in my case at least it was a complete waste of time just about to email Samsung again to find out their next corse of action as that was one attempt of fixing a problem they created so getting close to rejecting the TV as not fit for purpose!





Also recieved my usb stick this morning with version 1239.0 on it. And the same issue still exists, though i cant say i am not surprised. 

Got my USB today, installed it, reset smart hub and reset TV fully, but didn't fix it. Spoken to Samsung Chat again and sugested they replace my motherboard. She said that they will 'escalate this concern first to our headquarter'. They may well approve the replacement. They are going to contact me when they have a resolution to this issue (So I was told when I asked). I explained that I have been here before and then heard nothing. Doesn't look like this will be fixed before the world cup in 4k is over.

I was told by Samsung today, via email, when I queried it:


We understand that you wanted an assurance that the USB firmware to be sent via post will resolve the issue with BBC iPlayer. We'll be glad to assist you.


In regard to your query, the recent special firmware file (version 1239) has been tested and proven to resolve the issue with BBC iPlayer. This has been confirmed by our engineers from the headquarters who replicated the same issue using the same TV model and other 2017 Samsung Smart TV models having the same issue.


What you have read in the forum may be referring to firmware version 1230 which we initially released to fix the issue with BBC iPlayer and other apps, but we have some technical glitches and it did not contain the fix.


Please can anyone who has tried v1239 on a 50MU6120K confirm that it fixed the iPlayer problem?


1239 installed on UE40MU6470 and its still the same. So sorry to say Samsung but your engineers are wrong, this issue is not fixed. Pathetic !

Hi all just another update, there is another thread where the person was instructed via a phone call to Samsung to reset their smart hub press a combination of keys at the accept T&C's screen (for my TV the key combo is fast forward 289 rewind) pick the USA as the location of the TV (that deletes the apps and downloads apps for that country) go through the process of the TV adding apps, then turning the TV off and on again, THEN repeating the reset of the smart hub and replace the location with the UK and with that (fully deleting and then re installing the apps) all should work, not for me it didn’t, maybe it might for others who knows, but without sounding odd do so at your own risk !!! Just thought I would share that if others have not noticed the post. 

Firmware 1239.0 installed on to a 2017 UE40MU6400, reset and smart hub reset and NO IT IS STILL THE SAME no iPlayer, no NOW TV and no My5 so have we become the public testers for Samsung? Looks like as it obviously was not tested successfully on my TV.
Would it be to much to post on their (Samsung's) website the last known working firmware, give it a new number (so not to confuse the TV in the update process) and have that overwrite the STILL NOT WORKING new firmware as surely the firmware overwrites the last firmware thus removing the faulty line or lines of code that still exist
Top Liked Authors