Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Samsung Galaxy Note (GT-N8000)

(Topic created on: 29/07/20 17:19)
jules22
First Poster
Options
Tablets

I have a Samsung Galaxy Note  with model number GT-N8000.Android version 4.4.2 . Since it is outdated , cant install new apps like google meet, wps, etc. Is there any option to update the android version? 

0 Likes
Reply

2 Solutions


Accepted Solutions
Solution
Anonymous User
Not applicable
Options
Tablets

the option is to install a costum rom but you will void knox, not warranty since i suppose it is expired, you will face bugs and slowdowns. Stick with kitkat or buy another device unfortunately there is little you can do against normal obsolescence

View solution in context

0 Likes
Reply
Solution
AndrewL
Moderator
Moderator
Options
Tablets

@jules22: I believe that 4.4.2 is the most up to date Android version for the Galaxy Note, and there are sadly no plans to release later versions due to limitations in the phones hardware. You can always go to Settings > About Phone > Software Update > Update Now to check for available updates, however due to the age of the device it is unlikely to meet the minimum requirements for recently released applications. 


View solution in context

0 Likes
Reply
5 REPLIES 5
Solution
Anonymous User
Not applicable
Options
Tablets

the option is to install a costum rom but you will void knox, not warranty since i suppose it is expired, you will face bugs and slowdowns. Stick with kitkat or buy another device unfortunately there is little you can do against normal obsolescence

View solution in context

0 Likes
Reply
Solution
AndrewL
Moderator
Moderator
Options
Tablets

@jules22: I believe that 4.4.2 is the most up to date Android version for the Galaxy Note, and there are sadly no plans to release later versions due to limitations in the phones hardware. You can always go to Settings > About Phone > Software Update > Update Now to check for available updates, however due to the age of the device it is unlikely to meet the minimum requirements for recently released applications. 


View solution in context

0 Likes
Reply
jules22
First Poster
Options
Tablets

Thank you for your response Andrewl

0 Likes
Reply
jules22
First Poster
Options
Tablets

Thank you for your response Archer

0 Likes
Reply
dianamg
Apprentice
Options
Tablets

Mine is still 4.1.2. How can I upgrade officially