What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

Original topic:

Galaxy Tab A7 Lite wont instal (some system) updates

(Topic created on: 18-09-2021 11:42 AM)
First Poster

I purchased a Galaxy Tab A7 Lite 8 (32Gb) recently and had problems downloading app updates. Suspecting a storage issue I returned it for a replacement. However the new hardware has the same problem. Out of the box I've selected language etc, connected to my wifi (Virgin 200 Mbps) and input my Google account, I specified "Do Not Copy my apps and data".

The tablet goes through the setup process and appears to finish. Dragging down the "notifications" screen Google Play Store shows "Completing setup - Installed 1 out of 8 applications". Clicking on this shows Google Photos active but "stuck on 97%" (stuck as in for 2+hrs) all other apps shown as pending. If I cancel Google Photos the next app (Google Duo) starts downloading, that sticks on 33%. I cancel that and the next app (Google Play Movies & TV) starts to download and installs ! YouTube Music then installs as does Spotify, Microsoft Outlook and Microsoft Outlook. After this the re-queued Duo restarts and once again sticks at 33% (of 20.82 Mb). Cancelling this Google Chrome installs but them immediately re-appears as a pending update (but saying “updated moments ago”. Selected the Update option and it shows as “Pending”.

Visible from the Notification “pull down screen” Google Play Store is shown downloading That completes and Google Chrome goes “active”. (As an aside at this point Internal Storage shows 41% used (13.17 GB of 32GB)).

At this stage Google Play Store is no longer shown in the “pull down screen”. Selecting “Manage apps and device” shows Updating apps… - 1 update in progress, selecting “see details” shows Google Chrome still stuck at 76%. I cancel this and now the manage apps shows “Updates available  - 14 updates pending” which are mainly Google, Microsoft apps but also Netflix, Messages and the requeued Duo and Photos from above.

At this stage with the first device I went thru toy numerous online troubleshooting suggestions, namely clearing cache/data for Google Play Store, restarting the device, removal of my Google account, checking storage, internet connections all to no avail. At one point I reset to Factory Defaults and tried again -same result.

I also noticed that although I could download some of “my apps” others such as BBC Sounds, BBC News, BBC Sport would not download at all they simply stayed as “Pending” from Play Store, as a sort of test I tried downloading BBC Sounds on the new device and the same thing happens – that is it doesn’t appear to start the download.

Before I repeat what I did on the first device does anyone have any suggestions or is this tablet simply not compatible with Google’s Play Store ?

First Poster

Well fyi, three days later all outstanding updates were applied overnight and any app can now be installed. I can only assume some glitch with Google Play and/or my Google account !!

All working as designed.