Support

Open search

Galaxy Tab A 10.1 2019 Wifi Auto-connect issue with update to Android 10

Highlighted
Apprentice

Hello,

I recently upgraded my Galaxy Tab A 10 1 to Android 10.  Since I have done so, it seems that it will not automatically auto-connect to my home wifi.  There was not  a problem with this under the pre-installed  Android  9.  The issue seems to only occur on a cold boot and not during a warm reboot.  Has this issue been reported previously?  Are there any work-arounds for this?  Thanks for any help.

 

Sincerely,

-Bill Schuck

8 REPLIES 8
Highlighted
Moderator
Moderator

@Bill_Schuck

To troubleshoot this issue please head to Settings > Connections > Wi-Fi > Tap the cog symbol to the right of your router > Forget > Back > Toggle Wi-Fi off and on again > Select your router from the list of available connections, and run through the connection steps. Now, tap the 3 dots in the top right corner > Advanced > Turn On Wi-Fi Automatically > On > Wi-Fi Control History > Check if any apps have recently disabled your Wi-Fi. If this is the case, head to Settings > Apps > Select the relevant app > Permissions, and disable any Wi-Fi related permissions. If the issue persists, please try pressing the Volume Down and Power buttons together for around 10 seconds until the phone restarts, as this will refresh the software and address any issues that might be a contributing factor.

Highlighted
Back for More
Hi Bill,
In a way its a relief to see your post. YES YES YES I'm getting that same problem cold booting my Tab A (albeit the 2018 10.5" version of the Tablet *these are not phones Andrew*). Just like your example it was sweet as a nut under Android 9 and its ONLY since this 'upgrade' (and I use the word with reservations) to Android 10 that this has occurred. Just as in your case its only Cold boots that cause the problem (although many cold boots initialise WiFi fine ie its an intermittant fault on my device). Soooo glad to find your report after spending a hour on chat with Samsung support trying to convince them its something that they need to look at with their new Android 10 build rather than asking me to do (another) factory data reset. After major os updates I always factory reset as a matter of course. Will be watching on with interest!
Highlighted

Hello AndrewL,

Thanks for your  answer.  I have 4 nodes (so to speak) on router - as I have a router and an extender with 2.4 Ghz and 5 ghz active on each.  I followed your instructions, turned the tablet off and back on, and was auto-connected to one of the nodes automatically.  Should it fail to automatically reconnect again, I will  try resetting things as directed.  Thanks for your help with thus far.  I will go through a few more iterations over the next few days and will let you know things go.  

Sincerely, 

-Bill Schuck 

Highlighted

Hello FlyingKiwi,

Glad I could bring your (and my) problem to light.  As you can see by my  reply to Andrew, his suggestion has worked for one cold boot cycle.  I want to  try a few more cycles before I  declare his answer a solution.  Stay tuned.

Sincerely,

-Bill Schuck 

Highlighted
Back for More
In my tablets case this is an intermittent problem and it can be days between the problem cropping up (with no apparent rhyme or reason to when it will as long as its a cold boot - that seems to be the only common factor I can think of). My thoughts are that given my device has had a factory data reset since Android 10 was installed and Ive always turned off the automatically connect option referred to above (as was the case with Android 9), I don't see how it can be anything other than an issue with the new ROM/firmware thats causing this. My hunch is that the problem will return but if its like mine, it may take days to do so.
Highlighted

Bill,

That only works for 1 or 2 reboots. It doesn't fix the problem. The tab a boots up with the wifi showing it is on under settings, but it is really off and picks up no signals. A quick turn wifi off and on under setting always gets the wifi working again. This bug is definitely caused by the android 10 update and Samsung needs to send out a patch to fix the problem.

Highlighted

Johnnyc256,

 

I agree, I have been doing what you mentioned, and it does work (turning the wifi off and on again).  Thanks for  confirming that  the bug is because of the  Android 10 update.  I concur, Samsung needs to send out a patch.

 

-Bill Schuck 

Highlighted
New Member
I am glad I am not the only one with this problem. I hope it gets sorted soon as it is becoming a real pain.
Top Liked Authors