Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Boost offer for Galaxy Tab S7

(Topic created on: 03-10-2021 12:30 PM)
AB2016
Apprentice
Options
Tablets

Dear support

 

I Received the Epic Boost email on the 16th of September.

When going through the steps (signing into my Samsung account etc) I get to the redeem button.

It clearly mentioned 4 months, but when it opens the Youtube app, it only has a 2-month offer.

I did check for other posts before this one, but there were no answers.

Please could you assist?

Thanks

Andre

0 Likes
13 REPLIES 13
AndrewL
Moderator
Moderator
Options
Tablets

@AB2016: I'm sorry to hear that you're experiencing this issue. As an alternative approach can you try accessing the claim site on a desktop browser, and scanning the QR code via the link below to see if you have any more success? 

Claim 4 Months YouTube Premium Fold 3 Offer | Samsung UK

0 Likes
AB2016
Apprentice
Options
Tablets
Unfortunately I only get the 2 months offer and not 4
0 Likes
AB2016
Apprentice
Options
Tablets
Is there anything else I can try please? Or do I need to escalate this further?
0 Likes
Members_aQeUBSU
First Poster
Options
Tablets

I'm having the same issue, even though I scanned the QR codeScreenshot_20211007-095244_YouTube.jpg

0 Likes
AB2016
Apprentice
Options
Tablets
@andrewl I is there anything else that can be done?
0 Likes
AB2016
Apprentice
Options
Tablets
I would really appreciate a response from someone at Samsung.
Alibongo54
Explorer
Options
Tablets

No one at Samsung seems able to help with this issue, so many posts about it.

I have cleared cache, cleared history, got no add blockers and consistently it says not available in the UK! OR I get stuck in a loop of being told to sign in to my Samsung account when already signed in!

0 Likes
AB2016
Apprentice
Options
Tablets
I can get past that point. Have you set you default browser to Chrome?
0 Likes
ChrisM
Moderator
Moderator
Options
Tablets

Hi all!

As well as trying to refresh the page etc., could you please try the following - Go into Settings > Connections > Mobile Networks > toggle off VOLTE. Also, please turn off VPNs and Adblockers too!

Let us know if this helps!

0 Likes