Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

S8 - after update to Android 9 Pie, Always on Display not working

(Topic created on: 26-03-2019 10:28 AM)
joekoolness
Journeyman
Options
Other Smartphones

Hi,

yesterday I've upgraded my S8 Edge to Android 9 Pie but AOD (Always On display) is not working. I select it, configure it (I've tried all the possibilities), even change the clock style, but when I press the power button to lock it get's all black, no AOD.

When I unblock it, the AOD setting is disabled. It seems that somehow the AOD configurations/settings are not saved.

Anyone with the same issue? The app does not ask for permissions but it seems to need permission to access to files.

 

Thanks for the help, I really need the AOD working.

Rgds,

Ricardo.

2 Solutions


Accepted Solutions
Solution
Johnboy1979
First Poster
Options
Other Smartphones

You need to turn the AOD on after the update...

 

Settings

Lock screen

Always on display

Display mode

 

You can then set it to what you want 

View solution in context

Solution
joekoolness
Journeyman
Options
Other Smartphones

Solved with Factory reset

View solution in context

0 Likes
16 REPLIES 16
S_8_Plus
First Poster
Options
Other Smartphones

I have the same issue here, on my S8+. Any solution?

0 Likes
Solution
Johnboy1979
First Poster
Options
Other Smartphones

You need to turn the AOD on after the update...

 

Settings

Lock screen

Always on display

Display mode

 

You can then set it to what you want 

View solution in context

joekoolness
Journeyman
Options
Other Smartphones
Yep, I did that. Tried it several times with every configuration possible of Display Mode and even clock style. After that, as soon as the display fades, the AOD does not engage and when I access back to that setting, it's Disabled again.
0 Likes
Jtouch
First Poster
Options
Other Smartphones

I had the same problem, it's fixed now. Thank you  (Johnboy1979)  I did not relize the Display mode has three selections. I picked  Always On  and that fixed it.

 

Thanks again.

joekoolness
Journeyman
Options
Other Smartphones
Jtouch, you have a S8/S8+? It seems the S9 solves like that but not the S8.
0 Likes
Johnboy1979
First Poster
Options
Other Smartphones

44

 

33

 

22

 

11I have a galaxy S8. Are you going in to the phone settings menu? See screenshots

 

joekoolness
Journeyman
Options
Other Smartphones
Yes @johnboy1979 exactly that. And after the screen locks, the toggle Always On display returns to disabled. It does not "save" the configs I do.
0 Likes
joekoolness
Journeyman
Options
Other Smartphones
I've tried revert AOD installation to default, reinstall new version (4.2.05.1), all possible configs, clear cache, clear data, force stop. One curious thing: after uninstalling updates in AOD, when installing latest version, it says it requires new permissions (access to photos, storage) but Android does not ask neither add these to the app. When it finishes update, the "open" icon on the Galaxy Store remains light blue and does not allow to click. I am almost sure it's a problem with permissions: the AOD app is not storing the state "Enabled" (but rest of configs stay saved - clock style, display mode) and always revert to "Disabled" when lock screen engages.
0 Likes
joekoolness
Journeyman
Options
Other Smartphones
Samsung Support, anything else to try?