Support

Open search

Can't Setup Two-Step Verification

Highlighted
SOLVED
Apprentice

I've been trying for two days now to setup two-step verification on my Samsung account to no avail. What happened was I recently factory resetted my phone (Galaxy A71) and I'm trying to restore my data that was previously backed up to Samsung Cloud before the reset. The phone informs me that I must setup two-step verification in order to be able to restore the backed up data but when I try to do so, I get to the point where it says that the verification code has been sent to my phone via SMS, only problem is, I never actually receive any text message with the code.

 

No matter how many times I've tried, I just don't receive any message with the code via SMS. At this point, I'm beginning to wonder whether the SMS is even being sent at all despite what the UI is stating. I wonder this because WhatsApp didn't seem to have any trouble verifying my phone via SMS when I was re-installing my apps and setting them up. I don't seem to be the only person that is experiencing this issue either, lots of topics on here tells of many others not receiving their SMS also.

 

To me, this is clearly an issue on your end, either with your software, servers or both. Come on! it shouldn't be this frustrating to utilize Samsung's services.

 

I feel as though this issue could have been prevented if SMS wasn't the sole option for completing the two-step verification process. Why are there no other options for this, such as a QR code that one can scan with an authenticator app and pair it with the account to receive codes that way instead? Putting all your eggs in the SMS basket is foolish IMO.

 

Anyway, It would be greatly appreciated if anyone can provide a solution to this problem. I've already tried the suggestions from other topics, but to no avail sadly.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Update,

My country only has two carrier networks, my current number is with Digicel and it still doesn't receive short messages from Samsung for whatever reason, but then I tried sending the code to my old number which is with Bmobile (the other carrier) and it worked, so now I've gotten some backup codes and I've setup an authenticator app so I don't need to be bothered with SMS.

I am still curious as to why it doesn't send to Digicel (my current phone number) though, think I'll have to have a serious discussion with them, I mean they told me that all was well with my account and that they weren't blocking any calls/msg from any numbers but now I'm not so sure about that.

View solution in original post

Highlighted

This took me a while to solve. I even called Samsung Support and while they were very friendly and supportive, they were not able to resolve my issue. I actually found it by accident by changing my search criteria.

Anyway, here is the fix:

Go to Settings

Select Lock Settings

Go into Select Lock Settings

Make sure to DE-SELECT

LOCK NETWORK AND SECURITY.

 

This function blocks the Samsung 2 Factor Authentication codes.

I know the time spent resolving this whole thing is ridiculous but that's what I did to solve my issue - thanks to another user who is absolutely brilliant!!!

View solution in original post

83 REPLIES 83
Highlighted
Superuser I
Superuser I

Hi @Kenneth-071 

 

I noticed recently that my phone wouldn't back up without enabling the two step verification too.

 

When I enabled it the text came through as it should so I'm not sure why yours hasn't.

 

In this link another member has the same issue and a moderator here provided a phone number for Samsung Account's  》eu.community.samsung.com/t5/Other-Smartphones/2-Step-Verification-Issue. 

 

This is another thread too 》Trapped-Two-Step-Verification. 

 

I wish you all the best with this situation. 

 

🌈 Stay Safe  🌈 

 

 

Highlighted

I've got a Galaxy S6, performed a factory reset, SMS codes are being sent but they don't get accepted. It doesn't give me any error but it's geting me into a loop asking a for a code every time.

Highlighted
I did a factory reset on my Galaxy A71 about three times now but sadly it's the same, it says the code was sent but I receive no text message.
Highlighted
Update,

My country only has two carrier networks, my current number is with Digicel and it still doesn't receive short messages from Samsung for whatever reason, but then I tried sending the code to my old number which is with Bmobile (the other carrier) and it worked, so now I've gotten some backup codes and I've setup an authenticator app so I don't need to be bothered with SMS.

I am still curious as to why it doesn't send to Digicel (my current phone number) though, think I'll have to have a serious discussion with them, I mean they told me that all was well with my account and that they weren't blocking any calls/msg from any numbers but now I'm not so sure about that.

View solution in original post

Highlighted
Making sms code the only option for two step verfication for any authenciator is seriously stupid to the max . Pls do something about it Samsung dont drop your standard when you are on the rise customers will start losing faith if you dont make things convinient for them take note .
Highlighted

Everyone has this same issue but Samsung is not interested in solving it. 
It has been reported by many in another thread:
https://eu.community.samsung.com/t5/Other-Smartphones/turn-off-Two-Step-Verification/td-p/1442637 

Highlighted

WORKING SOLUTION !
Hi all,
I have just managed a workaround on my Samsung phone (running Android 7.0). 
Go to your Samsung account on PC. Go to the Security pane, and click where it says "Two Step Verification - ON". A pop up will ask for your accoutn password. The new page has a pane labelled "Password and Security" and at the bottom it has "Two-step Verification" and a right arrow link.  Click the arrow and a "Two-step Verification" screen opens. Go to "Backup codes" and click the right arrow link. A page with 5 codes opens - record or print these. Now return to your phone and log in to your Samsung Account. The Two-step Verification screen opens and you receive a 6-digit code by SMS. DO NOT USE THIS CODE as it will just loop around. Instead enter any random 6 digits. Now a red "incorrect code" message appears and you get a different screen with a "use backup code" option at the bottom. Select this and then enter one of you 5 backup codes on the next screen. Presto, you are in !! 

Highlighted

or enable the auth app option (use the  app called Authy as it has backup/sync/fingerprint options) it becomes the default when its enabled for loggin into with 2FA (you wont have to deal with SMS any more)

 

samsung really need to fix there site

Highlighted

This took me a while to solve. I even called Samsung Support and while they were very friendly and supportive, they were not able to resolve my issue. I actually found it by accident by changing my search criteria.

Anyway, here is the fix:

Go to Settings

Select Lock Settings

Go into Select Lock Settings

Make sure to DE-SELECT

LOCK NETWORK AND SECURITY.

 

This function blocks the Samsung 2 Factor Authentication codes.

I know the time spent resolving this whole thing is ridiculous but that's what I did to solve my issue - thanks to another user who is absolutely brilliant!!!

View solution in original post

Top Liked Authors