Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

WiFi issues after UI 5.1 update

(Topic created on: 23-02-2023 09:29 PM)
9378 Views
lichtie
Journeyman
Options
ever since I've updated to UI 5.1 the WiFi connection hasn't been working properly when using apps. the connection is still solid and the speed is as per usual (when I can get the speed test app to work) but when loading an app I get a loading screen or something similar. an example is on twitter, my timeline takes a long time to refresh and and video/photos don't load up at all. on mobile data 4g/5g everything is working perfectly. has anyone else been experiencing similar issues? 
45 REPLIES 45
AndrewL
Moderator
Moderator
Options

@SasamiPie: Please try heading to the Samsung Members app > Press and hold on the app icon > Diagnostics > Wi-Fi, and follow the on-screen prompts. Does this test flag any issues? 

If the problem is persistent across multiple Wi-Fi connections, then I recommend restarting your phone in Safe Mode, as this will disable all third party apps, and help to determine if the problem is stemming from an external source. To enter Safe Mode, press and hold the Power button until the 'Power off' prompt appears on the screen then release > Touch and hold Power off until the 'Safe mode' prompt appears then release > To confirm, tap Safe mode.

With Safe Mode enabled, head to Settings > Connections > Wi-Fi, and attempt to toggle it on. Furthermore, swipe from the top of the screen to the bottom, and tap the Wi-Fi option in the Quick Panel. If you're able to connect without issue, then please restart your device, and uninstall any apps that you have added since you performed the factory data reset. Let me know how you get on. 

0 Likes
aloychow
First Poster
Options

Have tried that already but it still does not work. The wifi button just dont really toggle ON. My wifi was working perfectly until One UI 5.1 update on my Z Fold 3, it is definitely a software bug.

maz3_boy
Explorer
Options

Dear MinRay,

ZF3 using from Hong Kong, with same issue, after update One Ui 5.0 to 5.1 and the phone restart it could not go on Wi-Fi. Tried "General Management" "Reset"  "Reset network settings" did not work, tried "Factory Reset" and did not resolve it.

Brought it in to service center and had the same telling me the Wi-Fi module is damage and need to change it, but because its link to the LCD it will need to be change as well (repair cost 4200hk$ 535US$ **bleep**) after 2 day back and forward they told me they give me 50% off the repair cost, as I did not want to wait anymore I paid for the new quotation and now waiting for my phone to get repaired because I press update 5.0 to 5.1 lol. 

maz3_boy
Explorer
Options

Z Fold3 using from Hong Kong, with same issue, after update One Ui 5.0 to 5.1 and the phone restart it could not go on Wi-Fi. Tried "General Management" "Reset"  "Reset network settings" did not work, tried "Factory Reset" and did not resolve it.

Brought it in to service center and they told me the Wi-Fi module is damage and need to change it, but because its link to the LCD it will need to be change as well (repair cost 4200hk$ 535US$ **bleep**) after 2 day back and forward they told me they give me 50% off the repair cost, as I did not want to wait anymore I paid for the new quotation and now waiting for my phone to get repaired because I press update 5.0 to 5.1 lol. 

0 Likes
maz3_boy
Explorer
Options

Z Fold3 using from Hong Kong, with same issue, after update One Ui 5.0 to 5.1 and the phone restart it could not go on Wi-Fi. Tried "General Management" "Reset"  "Reset network settings" did not work, tried "Factory Reset" and did not resolve it.

Brought it in to service center and they told me the Wi-Fi module is damage and need to change it, but because its link to the LCD it will need to be change as well (repair cost 4200hk$ 535US$ **bleep**) after 2 day back and forward they told me they give me 50% off the repair cost, as I did not want to wait anymore I paid for the new quotation and now waiting for my phone to get repaired because I press update 5.0 to 5.1 lol. 

0 Likes
SasamiPie
Pioneer
Options

@AndrewL  See, I have to be able to turn the wifi button ON in order for the wifi to be tested. I already tried that. It's already been factory reset. I specifically made sure not to back up my phone this time to avoid that variable. I used to provide tech support at a cell phone company in their customer service department. So, I know it's none of the apps. According to maz3_boy, if you look below, the wifi module is fried immediately after the UI 5.1 update. It's probably the same with my phone. So, I'm going to have to invest in unlimited data and definitely will NOT be upgrading my device, lest the same issue occur (though I couldn't afford it, anyway). Also, in safe mode it does not turn on. The switch button attempts to move over, but it remains greyed out. Below, it just says "Turning on..." until the switch button eventually moves into the off position. This is happening to enough people that I'm confident it's the update, and I wouldn't be surprised if a class action lawsuit crops up. I might just start one, seeing as the update came through less than TWO WEEKS after my warranty ended.

Tell me you're going to force me to upgrade every year without telling me you're forcing me? It's ********, and my confidence in Samsung is lost. When you pay hundreds of dollars, if not a thousand+, for a device, you expect it to last a little longer than this~

SasamiPie
Pioneer
Options

Dude. Even at half off, $267.50 is a lot of money, and it's ******** that we should have to pay to repair something that Samsung caused.

0 Likes
SasamiPie
Pioneer
Options

@AndrewL Are we ever going to get any follow-up to this? I already tried emailing the CEO office, but when I replied with the information they wanted, I got a mailer daemon. I can always write a new email to them from the website, though. I just didn't want to deal with not being able to reply to any message they send. However, if I have to, I would be more than happy to send them the link to this thread for reference. I've already gone rounds with customer service. I'm pretty sure it was something with the Intelligent WIFI that messed things up. The 5.1 UI update was supposed to make the slightly older phones function like the newer phones. However, it seems like the hardware wasn't able to handle those processes, and I'm not sure if someone neglected to check for incompatibility or not, if they even tested it on the S21 and Fold 3 before pushing out the update. Regardless, Samsung's unwillingness or inability  to provide actual solutions to this problem makes me want to open up a lawsuit, considering the only reason why it wasn't replaced under the warranty is because it ran out 10 DAYS before the UI 5.1 update was pushed through. I feel so angry and helpless that my grown adult self really just wants to cry. I won't be purchasing Samsung in the future. Your company has lost a loyal customer, because unlike the customer of the Apple cult, people buy Samsung products purely for the quality of the product. Without quality, it's NOT worth the money. I'll be sure to let the CEOs know ALL of this (and the headache I've had with customer service prior to coming to this forum) when I contact them here: www.samsung.com/us/support/contact/email-the-ceo/

0 Likes
SasamiPie
Pioneer
Options

I have a feeling that "intelligent" wifi software upgrade(s) burnt out the chip that allows the phone to connect to wifi, because the hardware was not compatible. Conveniently for them (or so they thought), this was 10 days after my warranty ended. I think either it was a HUGE screw up or they thought they could force people to upgrade by sending out an update that would damage their wifi capabilities.

0 Likes
spauldia
First Poster
Options

Good morning,

I have been experiencing literally everything that you folks describe - wifi toggler not turning on, etc. Nothing had solved the issue - network reset, factory reset, etc. 

HOWEVER, a while back in this feed, someone mentioned the Google WI-FI Provisioner app having been a potential cause of all of these wifi issues. Was hard to believe. Nevertheless, as a last ditch, I went into that particular app, cleared the cache, data, forced close, and ultimately disabled it (basically all the buttons), restarted my phone...I now have my wifi working correctly again. 

If you haven't already, I suggest giving this a try. It appears to have worked for me. My wifi module is clearly not fried.