Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Whatsapp keeps telling me your phone is not connected!

(Topic created on: 11-03-2021 01:41 AM)
13133 Views
Specialist
Pathfinder
Options

So I just got the S21U today, and everything is wonderful so far, but could not figure out how to make sure whatsapp stays running in the background....

 Background usage limits = put unused apps to sleep is OFF

sleeping apps/deep sleeping apps/ never sleeping apps is 0

I went into Optimise Battery Usage, and made sure NONE of the apps or services are enabled (so no optimization for anything!!!) 

I even tried, enabling Battery optimization, and then adding whatsapp to NEVER sleeping apps.  (did not change the behaviour)

"Allow background activity is selected" ..  (I tried turning on and off Put unused apps to sleep) IT is now off, as it made no difference. 

On all my other phones this seems to be working, never even had to do any of these settings. 

The only thing that makes sense is Power Saving MODE OFF! but the description udner it...

 

Learning usage patterns... 

 

Background network usage, syncing, and location checking will be limited and motion smoothness will be changed to standard.

I work all day and I need to be online on WhatsApp, what am I going to do, set the screen to never turn off so that the device is awake 24/7? 

Any suggestions? 

 

Thank you. 

38 REPLIES 38
Roosevelt Ross
First Poster
Options

if the network problem is okay then you should review the version you are using or try a different whatapp.

0 Likes
Members_IHMLGMY
Apprentice
Options

Hello - I have tried all the above regarding battery optimisation etc - and called Vodafone, who weren't particularly helpful.

In the end I have had no option but to return the phone and cancel my contact under the 14 day cooling off period.

WhatsApp Web is my primary business communication tool, and Samsung seem to be unresponsive in responding to this issue

0 Likes
Hasbean
First Poster
Options

Very sad Members_IHMLGMY - fortunately, my business does not rely on Whatsapp so I live with the problem that I rarely answer a Whatsapp message. I just get the alert that I have missed the call and have to call back. It worked better when I turned on data on the sim but then I got a surprise big bill for exceeding the data quota. I've read several threads on this problem and I am convinced Samsung are refusing to provide a solutuion.  

0 Likes
Specialist
Pathfinder
Options
That is because Samsung sucks.... But as I said after all battery optimisations have been disabled, I am now having no problems, however I use a third party modded WhatsApp, but I'm sure the original will also work.
0 Likes
MiguelTerry
First Poster
Options

you can use Whatsapp GB version. Most popular right now

0 Likes
jkmy23
First Poster
Options

I've got this problem and have just found the fix for it :smiling-face:

1. Go to Settings > Apps.

2. Then on the 3 dots on the top right, select Special Access.

3. Then look for Optimise Battery Usage.

4. Where it says Apps not Optimised, click on the down arrow and select All Apps.

5. Look for WhatsApp. And flick it to disabled :smiling-face:

6. Happy Days !

 

0 Likes
Specialist
Pathfinder
Options
This will not work. This was the first thing I did
0 Likes
Caonima
First Poster
Options

Please help.. i have the same issue.. So after u charge & drain the battery 3 - 4 times, whatsapp becomes ok ?
but it is hard to drain continuously.. so i turn on youtube when i sleep

0 Likes
lzmart
First Poster
Options

Guys, disable Samsung Max. Solved it for me.

0 Likes
TURKIYE
First Poster
Options

I was having this problem while using two WhatsApp application. I think it is necessary to make the following solution for Dual Messenger, which manages these two WhatsApp.
I removed Dual Messenger from the battery optimized list and the problem went away.

1. Go to Settings > Apps.
2. Then select Special Access from the 3 dots at the top right.
3. Then search for Optimize Battery Usage.
4. Where it says Apps Not Optimized, click the down arrow and select All Apps.
5. Search for WhatsApp and Dual Messenger and disable it.
6. Happy Days!

0 Likes