What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

Problem with Voice Typing - Does not work offline even with language installed.

(Topic created on: 05-06-2022 09:21 AM)

I am new to using Samsung products and an inexperienced Android user. I have just bought an A52.


I cannot get voice typing to work in offline (airplane) mode. Regardless of the app I am using, when I have to enter text using voice typing I get the message "Didn't catch that. Try speaking again."


In the Permissions settings, I have "allow apps to use the microphone" enabled.


In the Keyboard List, "Google Voice Typing" and "Google Voice Typing Legacy" is enabled.

Initially, "Samsung Voice Typing" was also enabled, however I have disabled it in an effort to solve this problem, but without success.


In the main Google app, under Settings > Voice > Offline Speech Recognition, English is installed.


What troubleshooting steps would you recommend to solve this voice typing problem?


@New-To-Sam-sung: Can you try heading to Settings > General management > Keyboard list and default > Google voice typing > Languages, and tap the box to the left of your preferred language. Now, when the Samsung Keyboard is open e.g. when composing a text message, tap the microphone symbol in the Keyboard Toolbar, and clearly dictate your message. You may have to tap the large microphone symbol at the bottom of the screen, if you wait too long after initially pressing the mic symbol in the toolbar. Le me know if this helps. 


Thanks Andrew for the reply.  I have gone to Settings > General management > Keyboard list and default > Google voice typing > Languages and English is set to the preferred language.

When I try to dictate a message using Google Voice, I am still unable to get it to work, even though English is set as the offline speech recognition language.

If I enable the Samsung voice input, I get a "no network connection" message.

In either case, I seem to be completely unable to use voice typing unless I have some sort of active connection.

Is there anything else I could try to solve this problem?

I saw a video on YouTube ( Google Translate - Offline Translation Not Working on Android [Fix]) that suggests Samsung has an unusual way of storing certain files -- I think it is some sort of virtual storage device.  According to the video this can result in Android not being able to find the downloaded voice files to use.  Could this have anything to do with this problem?



Thanks for giving this a try @New-To-Sam-sung . I have had a look at this and found the following steps to get this sorted:


1) Head into Settings > General management > Language and input > On-screen keyboard > Manage keyboards. Disable all except Google voice typing. 

2) Again go to Settings > General management > Language and input > Default Keyboard. Make sure Samsung Keyboard is selected.

3) If Speech-To-Text still does not work OFFLINE, you can try going to Settings > General management > Language and input > On-screen keyboard > Manage keyboards > Google Voice Typing > Offline speech recognition. Uninstalled and then reinstalled the English (US) language.


I accidentally it "Accept As Solution", but unfortunately, I'm still having problems.

I apologize for not responding any sooner; I just been very busy.

Under Settings>General Management I only have “Language” and not “Language and Input”


Then it’s “Text-to-Speech Output”, “Date and Time”, “Samsung keyboard settings”, “Keyboard list and default”, etc.


I tapped “Keyboard list and default” and have the following settings:

“Samsung Keyboard” (with no on- or off- slider), “Google voice typing”, “Google voice typing legacy”, “Samsung voice input”, and “Keyboard button on navigation bar”.


I have set the settings so that only “Google voice typing” is active.


Samsung Keyboard is active (it actually has no slider to turn on or off).


Unfortunately, I still can’t use Speech-to-Text offline.


I then tried suggestion number 3. Under Settings>General Management>Keyboard List and Default>Google Voice Typing there isn’t a “Offline Speech Recognition” heading only “Languages” which is set to English. I have tried deselecting English and selecting another language, and then changing back to English, but no success.


I am still only able to use Voice-To-Text offline.