Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

White filter when watching videos on the Samsung Internet app

(Topic created on: 09-09-2022 01:43 AM)
Emre0
First Poster
Options
Mobile Apps & Services

Hello everyone,

I noticed recently that whenever I watch videos on the Samsung Internet app, there always seems to be some sort of a white filter applied. It's not terrible, but black colors look gray instead and every other color looks more whitish as well, which is very strange.

When I rotate my screen, when it's in rotation mode the filter dissappears for a moment and then appears again as soon as the rotation is complete. Also, whenever I pull down the status bar, I can see in the background that the video colors are back to normal, but as soon as I pull the bar back up, the "white filter" is back again.

I tried taking screenshots to better visualise this, but whenever I take a screenshot, the colors always appear normal, even though I can see on screen that the white filter is there. I tried switching off dark mode, video assistant and several other functions, but nothing solved the issue.

This issue only happens with Samsung Internet, I tried several other mobile browsers as a test and didn't have this issue.

Does anyone else have this issue or a solution for it ? I tried contacting the Samsung Internet Support directly, but the "contact us" function doesn't seem to be working at the moment.

6 REPLIES 6
Hamd
Apprentice
Options
Mobile Apps & Services

Mine 2 

On top of that when i use 120hz mode there is green filter 2 

Luca-Ilie
First Poster
Options
Mobile Apps & Services

I also have the issue. 

The video is always whiter than normal. 

Same thing in the beta version. 

 

0 Likes
Solution
jacquelyn
Apprentice
Options
Mobile Apps & Services

Try this

You will need developer options enabled. To do so go to settings, scroll down to the bottom and press About Phone, go to Software Information, now find build number and what you want to do is press it 7 times. It will then ask for your pass code to make sure you want to enable developer options.

After that press back twice and developer options should be under About Phone. Go into developer options and scroll down until you find 'Disable HW Overlays' and toggle it on. And that's it. 

I would suggest turning it on when watching videos on the internet and turning it off when not watching as I have found it may affect some apps to not work properly. 

jacquelyn
Apprentice
Options
Mobile Apps & Services

Try this

You will need developer options enabled. To do so go to settings, scroll down to the bottom and press About Phone, go to Software Information, now find build number and what you want to do is press it 7 times. It will then ask for your pass code to make sure you want to enable developer options.

After that press back twice and developer options should be under About Phone. Go into developer options and scroll down until you find 'Disable HW Overlays' and toggle it on. And that's it. 

0 Likes
Emre0
First Poster
Options
Mobile Apps & Services

Omg, yes, this actually worked. I've been looking for a solution for so long that I had learned to live with it at this point, but disabling HW Overlays finally solved this issue. I just hope this doesn't affect the performance of the phone negatively, but even if it does, I'll just turn it on/off depending on what I do.

Either way, I don't know how you discovered this, but thank you very much for helping me finally get rid of an annoyance. Now I can watch my videos in peace again.

0 Likes
jacquelyn
Apprentice
Options
Mobile Apps & Services

That's great to hear. But yes I have found it may affect certain apps on the phone. I went to watch a movie on Disney+ and when the movie was playing, I could here the sound but the screen was black. But as soon as I turned of HW Overlays it was working again.