Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

How do I change the physical keyboard for Samsung Dex

(Topic created on: 21-04-2020 07:18 PM)
SteveWaring
Explorer
Options
Mobile Apps & Services

Currently when I hit the " key it types an @ (American keyboard, not the English one I am using).

 

See screen shots. I navigated to phyical keyboard from Dex on my PC, and chose English UK (Android) but it still says English US.

 

UK was chosenUK was chosenIt made no difference.It made no difference.

1 Solution


Accepted Solutions
Solution
SteveWaring
Explorer
Options
Mobile Apps & Services

i switched to Samsung keyboard on my phone before starting Dex. when I went to the settings it was showing English UK. The " key still typed as a @. i changed the language to English US (which as expected did not show properly) and then back to English UK, and after that the " key worked correctly. So I just have to tunr nof Smart Keyboard Pro, so I just need to do this when I use Dex.

View solution in context

0 Likes
24 REPLIES 24
AntS
Moderator
Moderator
Options
Mobile Apps & Services

Hi @SteveWaring, Yep, I'm getting similar to you when I tried to replicate this on my UK S10 on DeX... except my one is the opposite way around. 😕🤔

 

S10_DeX Physical Keyboard.jpg

 

I couldn't change the 'Samsung Keyboard - English (UK)' main title, despite what I selected and appears below it.

 

Before I started playing around with it the 'Samsung Keyboard - English (UK)' was set as 'English (UK) Qwerty style'. 

 

The " key typed an @ (in Samsung Notes) when I selected the 'English (US) Qwerty style' though; and then back to a " again when I selected 'English (UK) Qwerty style'.

SteveWaring
Explorer
Options
Mobile Apps & Services

No matter what keyboard I select, the keyboard stays as English US and just the language underneath changes and the key does not change. I've pretty much given up on using Dex as it's pretty unusable without proper keyboard mapping. It's a shame.

AntS
Moderator
Moderator
Options
Mobile Apps & Services

It's odd. I still haven’t been able to replicate your exact experience (I played around with main device input language settings for example). I did discover how to change the Samsung Keyboard though:

 

Settings > General Management > Language and input > On-screen keyboard > Samsung Keyboard > Languages and types > Manage input languages > [enable/disable desired language option, or download from available languages]

 

I switched to it 'Samsung Keyboard- English (US)' and back again.

 

DeX_language screenshot02.jpg

 

You've said elsewhere recently on the forums that you're using an S10+, so I'm guessing that's still the case. 🤔

 

Anything odd in the general language settings?

 

Or even with the Smart Keyboard Pro that's been installed? For example, does the key do the same if Smart Keyboard Pro is disabled in Language and input > On-screen keyboard > Manage keyboards?

0 Likes
Solution
SteveWaring
Explorer
Options
Mobile Apps & Services

i switched to Samsung keyboard on my phone before starting Dex. when I went to the settings it was showing English UK. The " key still typed as a @. i changed the language to English US (which as expected did not show properly) and then back to English UK, and after that the " key worked correctly. So I just have to tunr nof Smart Keyboard Pro, so I just need to do this when I use Dex.

View solution in context

0 Likes
The10thDoctor
First Poster
Options
Mobile Apps & Services

I have a S9+, and I am only having one problem with the Dex mode. I use a QWERTY type keyboard, but Dex Mode doesn't recognize the key responsible for both ?  (question mark) and (slash sign).

 

Does someone know how to solve this?

0 Likes
provangelist
First Poster
Options
Mobile Apps & Services

Hi, I have the same problem with my German keyboard CSL Mini Keyboard 300175. Although I have changed all the settings in Physical keyboards part in Language settings, it always types in English. I cannot use the letters such as ä or ö.

Thanks

mabo3073
First Poster
Options
Mobile Apps & Services

I ve the same problem with swiss german keyboard - from the helpdesk I got instructions on how to setup the keyboard (based on android 10 and were everything was fine) - this error happens starting from Android 11. needless to say that the helpdesk was useless....

MisterDister
First Poster
Options
Mobile Apps & Services

Hello! I got the same problem, suddenly I can't use letters like ä or ö when I write on DeX. I have been using DeX almost daily for two years and woke up to this and frankly it totally destroys the use for it. I believe it started after an update, don't know which one but everything is selected correctly in settings, QWERTY Swedish. This problem must be fixed soon! I'm writing my school project on DeX and don't have a computer at home. DeX IS my computer.

0 Likes
JJL-FI
Apprentice
Options
Mobile Apps & Services

Accessibility service  is the problem for now, before some new update comes. I had Boldbeast call recorder activated, then the keyboard are in english. When i take it off, the keyboard are in nordic language like the phone.

 

0 Likes