Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Google Calendar defaulting to Samsung My Calendar

(Topic created on: 27-09-2022 04:24 AM)
9997 Views
SungOne
Student
Options

The preinstalled Google Calendar app on my Samsung Galaxy A71 phone places all appointments I create on my phone in Google Calendar into a, presumably Samsung only calendar called, My Calendar. Appointments in My Calendar are not visible in Google Calendar when viewed from other devices, which is very unhelpful. While appointments made on other devices into Google Calendar are visible on my phone. All appointments made on my phone default into My Calendar, even when I "turn off" My Calendar in my phone's Google Calendar app (this only appears to make My Calendar temporarily invisible on my phones Google Calendar app).

How do I force appointments made on my phone in Google Calendar go into my Google Calendar calendar instead of the useless My Calendar?

8 REPLIES 8
Pugs1957
Samsung Members Star ★
Options
I am a bit confused by your post so sorry if I misunderstood. As far as I can remember Google Calendar is not pre installed and Samsung My Calendar is the default app. Just install Google Calendar and set it as the default Calendar app through settings, apps.
reservedzz
First Poster
Options

It’s unclear what you are trying to say in the OP. Apparently, these two apps are not interconnected, and all the appointments you create in Google Calendar should be visible on all the devices you use. That’s how a google account works – there is constant synchronization between all the devices you use.
If these two apps are confusing, you might try to use something simpler like this printable june 2023 calendar. You can just print it and use it as a regular calendar. This way, all your events will be visible, and you will not have problems looking for them.

0 Likes
alachip
Apprentice
Options
Follow pugs1975 instructions
0 Likes
plo009
First Poster
Options

Hi, did you manage to find a solution to your problem? I'm in exactly the same shoes as you, even went as far as removing the samsung calendar app using adb, but as long as I'm logged into my samsung account, events always default to "My Calendar" which doesn't get synced to my google calendar on other devices.

chart2006
First Poster
Options

There is no "default calendar" and that's not what the OP is asking about. His problem is when he goes to create a new event within Google Calendar, the default save location or account is "My Calendar" which is his Samsung account. As a result it doesn't save to his Google account where his calendar events are shared with other people. 

0 Likes
chart2006
First Poster
Options

Yes, first deselect both My Calendar and Samsung Calendar to prevent them from showing in your calendar in general. Touch the three bars in the upper left corner then deselect the two calendars. Then go and create an event. Under where the title goes is the calendar it's going to save to. Touch it and select "Events." Your Google based events should be the first one if no your only. At that point just close or disregard the event. It should start defaulting to it going forward. If it doesn't, try actually creating an event. That being said keep tabs on it when creating events to make sure it doesn't go back.

0 Likes
SungOne
Student
Options

Sorry plo009 about the lateness in replying, I had trouble finding my login details till now. Yes I did eventually solve the problem. Like you I deinstalled Google Calendar and reinstalled it, but I had to do a few other things to turn off the Samsung Calendar, in a way similar to chart2006's description. What I found I had to do is to turn off Samsung Calendar option under the Google Calendar app settings (three horizontal bar icon in upper left hand corner). I've deselected the 'Samsung Calendar' tickbox, however I also had to deselect one of the two 'My calendar' tickboxes. On my phone these two 'My calendar' tickboxes are immediately below the 'Samsung Calendar' option, the first has a round coloured icon and no tickbox, this is my Google calendar, below this is the Samsung 'My calendar' tickbox, deselecting this stopped my events going into the Samsung calendar and sent them to the Google calendar. There might be other ways to doing this, but, this way has worked so I no longer have problems and inherent confusion of two different calendars being referenced by the one app. I hope this helps solve your problem and good luck.

emmaja
First Poster
Options
Thanks @chart2006 just followed your advice to fix it for me
0 Likes