Support

Open search

Galaxy Watch, default messaging app

Highlighted
First Poster

Hi everyone,

I've a Galaxy Watch (42mm, SM-R810) and a Galaxy S9, which I use Textra on for my texts as the default Messages app is a bit rubbish.

 

If I try to go to Messages on my Watch, I get the message 'Can't retrieve messages. Change your default messaging app to Messages?' and a tick or a cross. Tapping the tick tries to change the default text app on my phone to Messages and shows the messages screen on my Watch, including all of my texts. Whereas tapping the cross takes me straight to the messages screen on my Watch with all of my texts showing, which I can read, reply to, delete etc.

 

Is anyone else getting this? If it works for everyone, can Samsung update the Watch OS to just let us interact with our messages, without the error message, as it seems to work just fine without having to use Messages on my phone?

 

Thanks

14 REPLIES 14
Highlighted
Observer

I hope this isn't the case. I'm planning to buy a Galaxy Watch Active with my $130 credit from my Galaxy S10+ purchase. I'm using Google Android Messages as the messaging app on my phone because the default Samsung Messages app won't show SMS notifications on my Macbook Pro. But if using Android Messages means I won't get notifications for SMS on my Galaxy Watch Active, then I'll be in a pickle! 

 

https://twitter.com/SamsungSupport/status/1110976336133132288

Highlighted

The annoying thing is that everything works fine, even if you are not using the Samsung messaging app..

You do however get an error message on the watch saying that it can't retrieve the messages with a tick and a cross. However if you click on the cross everything works fine with a third-party messaging app.

It's really annoying that you have to click the cross every time to get to your messages there and I wish Samsung would get rid of this!

Highlighted
First Poster

Hey there. 

 

I found a solution. I use Google messages for my texts and was getting the annoying default message app warning.

I tried everything from resetting trying other apps, going through contacts as suggested and nothing worked. 

 

However I installed the watchface "App Launcher GA" and it works now. The shortcut from the watchface itself seems to bypass the ***** warning .

Tell me if it worked for your text app.

Highlighted

Thank you so much for this advice. I did just what you said, turned the watch off, turned it back on....and BOOM...I'm now receiving messages my messages from the TEXTRA app. :smiling-face: 

Highlighted

I tried looking on the Watch faces section on my phone and there is no way to search. So I can't search there for the Launcher GA. I also went on the watch itself to the watch faces area to try to find that launcher and there is no search function there and that Launcher GA is definitely not in the first bunch of ones that I am scrolling through. Maybe I'm looking in the wrong spot to find this launcher you are talking about. Additionally, when you search on apps on the watch I do not see that one come up (and there when looking for a new app there IS a search function). Sp please let me kow where this Launcher app GA is and do you have to have it enabled? I am using textra on my Note 10+ and I also don't see anywhere in the textra app on the phone where to enable that it should send messages to the watch. Any help would be appreciated.

Highlighted

Hey, you can search for it on the Galaxy wearable app like you search for other watchfaces.

 

Here's the direct link:

http://apps.samsung.com/gear/appDetail.as?appId=jvLua0eu6I

Highlighted

So I downloaded app launcher GA. Now how do I make my text app, which isn't the default one allow me to put it on my watch? Thanks 

Highlighted

i tried that watch face and it did not work for me.

Highlighted
New Member

Although I'm not able to initiate new messages on my watch through google messages app, I'm able get notifications, see the messages (including pictures) and reply to the messages from my watch.

If you are not getting notified on the watch, you will need to enable notifications for Google Messages in the Wear app on your phone.

Top Liked Authors