Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Do not disturb schedule not turning on.

(Topic created on: 26/05/20 07:35)
JacobGates
Apprentice
Options
Mobile Apps & Services

I bought a Samsung Galaxy a51 a couple of weeks ago. The do not disturb schedule doesn't seem to be working properly. I was woken up last night from notifications and had to manually set do not disturb. I saw a couple of those posts here about DND not working for them but their problem was a little different and older posts.

0 Likes
Reply

1 Solution


Accepted Solutions
Solution
JacobGates
Apprentice
Options
Mobile Apps & Services

Okay, found the cause. But I don't completely understand it. It seems when I have a time schedule set in the tasker app, my phone thinks that's an alarm. And when it's that time, DND is disabled because an "alarm" went off. I came to this theory because my clock widget shows the next alarm, and I noticed it shows the time of the schedule of tasker if it's sooner than an actual alarm. Also DND turned off at the time of this tasker schedule. This seems to just be a conflict in how tasker interacts with my phone so I don't know how to fix it. In the meantime I have tasker activating DND and that's working fine. Basically if anyone else is having this issue and you have tasker installed, either remove it or use it for everything.

View solution in context

0 Likes
Reply
8 REPLIES 8
TessM
Moderator
Moderator
Options
Mobile Apps & Services

Hey @JacobGates ,

 

let's try to get this sorted.  I can see that there are new options available for the Do Not Disturb feature on Android 10. Can you please check Settings> Notifications> Do not disturb, in particular Duration. Has this been set correctly? Is the phone software and apps all up to date and is this happening since day 1?  

JacobGates
Apprentice
Options
Mobile Apps & Services
Hi @TessM,
Duration is set as "Ask every time", but I don't usually manually set DND, instead I have schedules set and there is nothing in duration related to the schedules. I have 2 schedules, one for weeknights and one for weekends. I expect it to turn on DND automatically at the start time that I set there, but it isn't doing that.
Everything is up to date, just now did a check to be sure. It's hard to say if it's been like this since day 1. I set the schedule and just forgot it, because I didn't question if it would work or not. So it's possible that it worked before but it's also possible that it didn't, but I just didn't get any calls or notifications during that time.
0 Likes
Reply
TessM
Moderator
Moderator
Options
Mobile Apps & Services

Would you be able to place this in Safe Mode to see if this works? Safe Mode disables all third-party apps and so if the notifications start working in this mode, we can confirm it is being blocked by a third-party app. If so, you will need to locate and either uninstall or contact the app developers for a fix.

 

To do this press and hold the Power button until you see Power Off, Restart, and Emergency. Press and hold the Power Off icon until it shows a Shield, tap the Shield and the device will restart in Safe Mode.

JacobGates
Apprentice
Options
Mobile Apps & Services

Booted in Safe Mode and set a new schedule for 1 minute later and it worked. Booted back into normal mode and waited for all my normal 3rd party apps to load, set a new test schedule for 1 minute later, and weirdly it worked. I have no idea what is going on here. I do have the app Tasker installed which is runs some things around the same times my DND schedules are turned on, so I thought maybe that was causing a conflictand. But I changed the Tasker things to the same time as a test DND schedule, DND still activated. Really weird. This is the worst kind of issue, one that happens seemingly randomly, lol.

 

It seems you are on to something though, maybe there's a 3rd party app that is causing an issue only during the night (therefore not affecting the test schedule).  I guess I will continue to to monitor what is happening when it doesn't activate. Thanks for the support! If I find the problem, I will post it here.

TessM
Moderator
Moderator
Options
Mobile Apps & Services

Happy to help @JacobGates , please do keep us updated about this. 

0 Likes
Reply
Solution
JacobGates
Apprentice
Options
Mobile Apps & Services

Okay, found the cause. But I don't completely understand it. It seems when I have a time schedule set in the tasker app, my phone thinks that's an alarm. And when it's that time, DND is disabled because an "alarm" went off. I came to this theory because my clock widget shows the next alarm, and I noticed it shows the time of the schedule of tasker if it's sooner than an actual alarm. Also DND turned off at the time of this tasker schedule. This seems to just be a conflict in how tasker interacts with my phone so I don't know how to fix it. In the meantime I have tasker activating DND and that's working fine. Basically if anyone else is having this issue and you have tasker installed, either remove it or use it for everything.

View solution in context

0 Likes
Reply
David_C2020
New Member
Options
Mobile Apps & Services

Well, I have the same problem and I don't have the Tasker app.   I rebooted my Sumsung A50 (Android 10) in safe mode and still no luck.  My DND does not turn on as scheduled.  It does work manually though.   Appreciate any other ideas.

Members_Zj6zVJ9
First Poster
Options
Mobile Apps & Services

This worked for me too on my A51 5G. Thank you.

0 Likes
Reply