What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

Can't update/install Smart Switch

(Topic created on: 08-09-2022 03:46 PM)
First Poster

Apologies I'm posting this in the wrong place. I'm hoping someone can help me.

I've recently had to ditch my Galaxy A50, because it suddenly stopped recognising my sim. Could still use WiFi, but no SMS, phone calls (except WhatsApp etc.), or mobile data.

A new sim didn't resolve the issue, so I've now upgraded to a new Galaxy A53. I'm trying to copy everything across using Smart Switch.

The A50 wouldn't let me do this until I'd updated Smart Switch. I tried to, but the process just went on indefinitely, stuck at 83% for hours. I tried rebooting phone, uninstalling Smart Switch, and installing it again from Google Play Store, but the install process also got stuck infinitely. 

Tried rebooting phone and clearing my data from the Play Store app to break the cycle. Now, after that, the Play Store won't launch at all. It just shows me a picture of a sad-looking satellite. 

Tried installing Smart Switch from the Galaxy Store via chrome. Galaxy Store had to update first. It got stuck updating. I cleared data and rebooted. This time it didn't insist on update, so I guess the previous one had been successful. Went ahead and tried to download and install Smart Switch. It tried for an hour, then gave me a non-specific error message. 

Now I'm stuck and not sure what to do. I'd rather not have to transfer all my stuff over from my old phone piecemeal. 

WiFi seems to have been working fine through this whole process. I can browse in chrome, do all the normal stuff, no problem. 

Any advice would be greatly appreciated! Many thanks. 

First Poster

I've got the same issue when backing up my Note9 to my computer.  While it's stuck at 83% the transfer is still ongoing, the "documents moved" counter is slowly moving up and up.

There must be a feature that is slowing down the transfer speed.