Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Adding Outlook Calendar to Samsung Calendar App on Note 10

(Topic created on: 30/01/20 15:01)
Sean16
First Poster
Options
Mobile Apps & Services

What am I missing? How do I add Microsoft Outlook calendar, which my main calendar, to the Samsung calendar app. I do have MS Outlook app installed and running on my phone. My concern is that I want to see all of my calendar on my watch, the Active 2, and to do that I need to have the Samsung Calendar showing my Outlook items. I open the Samsung Calendar app on my phone, go to settings, add new account and it lists 3 possibles; Samsung account, M exchange, Google. The Samsung Account and Google are active already (a blue dot out to the right). To do something I selected M Exchange, it then shows 'enter your email address', I enter my Outlook email, then a line pops up 'you have already added this account'. When I look at the available calendars to display it shows 'My phone',  'xx@gmail.com', and 'App ents'. The calendar I want to sync, 'xx@outlook.com' isn't an option. Again, what am I missing and how do I get my Outlook calendar events to sync to the Samsung calendar? Thak you.

1 Solution


Accepted Solutions
Solution
BboyNikki
First Poster
Options
Mobile Apps & Services

I found the solution man ! 7 months mate but well

 

I had 100% the same situation and problem than you.

 

What I did and what you need to do :

- go to Outlook application

- go to settings (dropmenu ln the left then gear icon)

- Here you ll see "Mail accounts" section, and under the title uou ll see you @outlook.com email. Click on it.

- On the new settings page shown, toggle the switch "Sync calendars".

- accept whatever thing it asks. From memory it told me Google will have access to you calendar or something like that. Accept everything.

 

- Now your outlook calendar should show in the native samsung Calendar app.

It did for me.

 

Hope it can help someone

View solution in context

17 REPLIES 17
pvandamcom
First Poster
Options
Mobile Apps & Services
Same problem here. No native add of the Microsoft mail and calendar service settings possible. I use a workaround to publish the calendars through outlook.com then add the published calendars on the Google calendar side. This way they show up on the Samsung calendar app. A direct sync option would be better, but I also have not found this on Android One with the native Google Calendar app either.
0 Likes
Reply
Jezza1
New Member
Options
Mobile Apps & Services

Just add your outlook email to the default email app. Outlook calendar will then sync with your phone calendar.

Solution
BboyNikki
First Poster
Options
Mobile Apps & Services

I found the solution man ! 7 months mate but well

 

I had 100% the same situation and problem than you.

 

What I did and what you need to do :

- go to Outlook application

- go to settings (dropmenu ln the left then gear icon)

- Here you ll see "Mail accounts" section, and under the title uou ll see you @outlook.com email. Click on it.

- On the new settings page shown, toggle the switch "Sync calendars".

- accept whatever thing it asks. From memory it told me Google will have access to you calendar or something like that. Accept everything.

 

- Now your outlook calendar should show in the native samsung Calendar app.

It did for me.

 

Hope it can help someone

View solution in context

Sean16
First Poster
Options
Mobile Apps & Services

Thank You!!! It Worked!!! 
Outlook, settings, sync calendars.....toggled to off then back on..... 
My calendar now shows up on my Active 2
Thank you again

pvandamcom
First Poster
Options
Mobile Apps & Services

This would be a great solution "Outlook, settings, sync calendars" but in my Outlook on Android 10, this calendars sync does nog exist. Could it be brand new? Not rolled out to me yet?

I do have Sync Contacts, and that works perfectly, synching the Outlook contacts to the local system contacts app.

And we're trying to get the Outlook calendar into the local calendar app, so this option would definitely be a solution, but I don't have it. What version of Outlook are you guys on?

I;m on 4.2036.3 (42036813) 

0 Likes
Reply
BboyNikki
First Poster
Options
Mobile Apps & Services

I m on galaxy A8 2018, Android 9, and my outlook is on 4.2035.2 (42035805).

 

So I guess Android 10 changed the way Calendar sync permission works.

 

Try the 2nd accepted solution of This post .

It is the same problem, with galaxy s9 (which shoulf be on Android 10 i think).

 

In the second accepted solution (the one from the user "Cage", it is said that :

- It is the samsung stock email app that handles Calendar sync permissions.

- So you need to install it(if you dont have it preinstalled),

- check in phone general settings that the stock email app has storage permission ON,

- connect your outlook email account in the stock app,

- set in the stock app the Calendar sync setting ON,

- set in the stock app the refresh frequency from 6 months to "always synced".

 

I can't verify this process since I cant update to Android 10. 

I hope it ll work for you !

 

Dont hesitate to look through the whole 7 pages of the post as people discuss of edge problems they encountered and how to solve it.

 

0 Likes
Reply
pvandamcom
First Poster
Options
Mobile Apps & Services

Yes, this works!! Never realised that the stock Samsung e-mail and calendar app played a role in this, I was always trying these things with the Google apps, but this actually makes a lot of sense!

I'm now happily synching my outlook.com (personal) and office365 (work) calendars to the default calendar app on my phone. This way, I can show/view the calendar in my car as it only loads appointments from the default calendar on the device.

 

The only wish I have remaining (wich is a new problem :-), is that the Microsoft Family Calendar will get synched by the "Exchange Active Sync" module at some point in the future. 

It seems that Samsung is using this service to get the trick done, but might not have build support for it (might also be a Microsoft ommission)

0 Likes
Reply
Members_4e7zKxW
First Poster
Options
Mobile Apps & Services

You absolute hero! Thank you!

0 Likes
Reply
Mudassir93k
New Member
Options
Mobile Apps & Services

Thanks BboyNikki. This worked like a charm!

0 Likes
Reply