Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Wi-Fi Calling doesn't work

(Topic created on: 15-02-2024 05:44 PM)
821 Views
iMikes
Explorer
Options
I can't use WiFi calling! PLEASE HELP!

I have a z flip 3, my wife has an S22 ultra. Both of us have WiFi calling enabled, but no matter what we do, it calls through the network and not WiFi. We live in an area with very poor network so the line is always bad. We need WiFi calling to work. 

My work around used to be to turn on Flight mode and then turn on WiFi, and this would automatically prioritise WiFi calling. But in a recent update, samsung have removed this ability. So now when you turn on flight mode and WiFi, if you try to make a call, you get a message telling you that flight mode must be turned off first. This wasn't a problem in the past but now we're screwed. What do we do? 
0 Likes
16 REPLIES 16
Glenntech
Samsung Members Star ★
Options
Have you contacted you network provider to have them enable WiFi calling?
If they support this.
Some networks like O2, you can go into the My O2 app and do this yourself
iMikes
Explorer
Options
Yes. Just got off the phone with them. We're on three. They said they haven't disabled anything.

Spoke to samsung too, we went through diagnostics and all sorts. Was on the phone for 1hr. No resolution.

Again, before a recent update from Samsung, I could just force wifi calling through flight mode. That doesn't work anymore and unless there's no signal at all, the phone won't switch to WiFi. I don't know if any way to deliberately have no mobile signal/network.
0 Likes
keith30
Maestro
Options
The 3 network has been having problems with their network the last few days. Try to reboot your device
0 Likes
iMikes
Explorer
Options
So I've found a fix for my z flip 3. I used "hey Google" and asked it to "open WiFi calling".

This gave opened up WiFi calling preferences, which allowed me to select to priotise WiFi calling, which was disabled before and was priorising mobile network calling.

I have no idea how to get to this screen without using Google to open up this page. When I go to WiFi calling in the phone app, the preference settings aren't there. I've this same fix on my wife's S22 ultra but it doesn't come up.

So this WiFi calling preference option is hidden somewhere within the phone and I have no idea how to manually navigate to it. 1708023429102.jpg
0 Likes
BandOfBrothers
Samsung Members Star ★★
Options

So @iMikes is Wi-Fi Calling now working after you activated this setting 🤔 


Daily Driver > Samsung Galaxy s²⁴ Ultra 512Gb ~ Titanium Black.

The advice I offer is my own and does not represent Samsung’s position.
I'm here to help. " This is the way. "

0 Likes
iMikes
Explorer
Options
Yes. But I haven't been able to activate it on my wife's S22 Ultra. So I haven't found a full proof fix yet
0 Likes
GuzziBoy
Voyager
Options
Hi, If you click on your Phone app then the three dots top left then settings then down to Wi-Fi Calling and click on the text not the switch. You then get an option for calling preferences either Wi-fi or Network. I have mine set for Wi-Fi. just wondered if this will help. If already tried my apologies cheers
0 Likes
iMikes
Explorer
Options
I appreciate the advice. I did try this but nothing comes up. No preferences are showing unfortunately
0 Likes
GuzziBoy
Voyager
Options
this is screen shot of options1708075542233.jpg
0 Likes