Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with whatsapp media

(Topic created on: 29-01-2024 06:36 PM)
1983 Views
djd1983
Journeyman
Options

Hi 

I've recently upgraded to the s24 from an s21, and when I transferred all my stuff onto my new phone, all my whatsapp videos and pictures that I've sent to other people/groups have ended up in my gallery. If I delete them from my gallery then it deletes them from my whatsapp. I don't want them in my gallery as there's alot and i never had this problem before I changed phones. I've tried all the media visibility options and stuff I've seen online but nothing seems to work. Could someone please help 

0 Likes
7 REPLIES 7
Reylob
Samsung Members Star ★
Options

Open "My Files"

Open settings the three vertical dots.

toggle on, "Show hidden system files"

Navigate to:

Android -> media -> com.whatsapp and create a file called ".nomedia" the dot '.' in front indicates that it is a hidden file.

That should stop the Gallery app from searching that directory for media.

It will behave the same for any other directory. If you create a file called .nomedia, that directory will be excluded from the Gallery.

djd1983
Journeyman
Options
They are still in my gallery. It did say yesterday on them but now it says 27th January. Any ideas why?
0 Likes
Reylob
Samsung Members Star ★
Options

If you created the file with name exactly  .nomedia , then go to settings -> apps -> find Gallery -> storage -> Clear cache / Clear data.

It could be that the Gallery app still have some cache keeping those paths.

I am sorry to repeat myself. the file .nomedia has to be created exactly like that, it cannot have extensions or anything else.

After you open Gallery again, it should repopulate ignoring any directory which has the file .nomedia

0 Likes
Obsydian
Samsung Members Star ★
Options
I have a habit of daily housekeeping and keeping and moving whatsapp media and keeping such a folder non existent.

But yes this does mean, if you go into WhatsApp its missing.

You can simply hide the WhatsApp folder in the Gallery settings, click.the 3 dots and select hide albums
Regards Obsydian - (Car & Tech Evangelist)

MY DEVICES: ZFold4, Watch6 Classic, Book2 Pro i5 5G [Laptop], Buds Pro2, M70A 32 & 43”; [Monitor], Smart Tags, Dell Inspiron G5 [Laptop] / FAMILY DEVICES: ZFlip3, ZFlip4, ZFlip5, Watch6 Classic, S8 Ultra; S7+ [Tablet],  Buds Pro, iPhone 12, iPad Air 2, Air tags, iPad Mini 5, iPad Pro 12.9 GEN2 [Tablets] / HOME DEVICES: QN95A [TV], Q900A / SWA900S [Soundbar, Rears], MC28M6075 and MC32K7055 [Microwave], Jet 75 Complete (Vacuum), Samsung Level [Speaker]
djd1983
Journeyman
Options
Where do I find the hide albums as I can't find the option. I've tried to clear cache and clear data but still nothing
0 Likes
djd1983
Journeyman
Options
This is what I done 1706552968836.jpg
0 Likes
djd1983
Journeyman
Options
I've managed to find the hide albums and it's worked so thanks for your help