Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

S23 ultra lost 5g connection from lycamobile

(Topic created on: 3 weeks ago)
240 Views
send2mitko
Apprentice
Options
Hello, my s23ultra lost 5g from lycamobile. It will only connect to 4g+. I tried everything what I read on internet and what I was told by Lyca and Samsung support. I even ordered a new sim, changed to esim, then back on physical sim. It stays the same. Only 4g+. And it was working fine till 3 weeks ago. The only thing I havent done is master restart but want to avoid that. Any suggestions will be appreciated.
5 REPLIES 5
Piper123
Samsung Members Star ★
Options
Hey there

Appreciate you've tried "everything". Have you checked on EE's coverage checker that 6g is still available in the area and that there isn't any issue locally with the local masts?
0 Likes
send2mitko
Apprentice
Options
Thank you for your reply. The problem exists for the last 3 weeks, after samsung update BTW, and since then I was traveling all over London and no where was able to pick 5g connection, so it's not the local mast. I gave up now after hours and hours of trying, spent all my free time off work to solve that with no success,so it doesn't matter no more. Live just go on without 5g lyca and I will move on.
0 Likes
GordyW
Journeyman
Options
Finding Ultra 24 connection issues constantly. Both data connection and WiFi will just decide to drop. Having to do Airplane mode shuffle into double digits everyday. Woeful issue for a flagship phone to have.
0 Likes
G0UDG
Voyager
Options
Getting the same with my S23ultra the mast is a 5 minute walk from us. Connection keeps going LTE showing then the no signal circle crossed out randomly. My Sweetheart/Wife has the Same phone and the same issues. We are on EE phones are factory unlocked Dual sim purchased direct from Samsung
0 Likes
Milek926
First Poster
Options
About month ago my 5g stopped working on my s23 ultra with lycamobile. It was fine and I was hitting 300mbps without any doubt.

Have you found any solution for this?
0 Likes