Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Google play apps keep automatically updating when I've turned off autoupdate

(Topic created on: 20-04-2023 09:56 AM)
2726 Views
Princelee
Explorer
Options
I an application that I've set to not automatically update because I want to manually update it as it causes issues each time its updated but for some reason the app keeps updating itself even though I've set my Google play to not auto update and I've disable automatic update on the app directly is there something going on that I don't know about ? Because I don't understand why it is randomly updating itself when I've already set it not to

image


13 REPLIES 13
keith30
Maestro
Options
You don't say what app it is that keeps updating. Any problems with a app is usually best to uninstall it and then reinstall the app after deleting all data and Cache first.
Princelee
Explorer
Options
Hi the reason I didn't mention which app is because it does it with all my applications not one specially its like turning off the auto update doesn't affect google play store
0 Likes
Bigtasty65
Hotshot
Options
I had the same problem as you with the Playstore updating apps automatically. When I already had the setting set to never.
What I did was make sure my setting was turned off. Then I went to the phone settings>apps, scrolled down to the Playstore. Tapped on that, then storage, and cleared cache and data.
Then relaunched the Playstore, selected the account again. Then made sure in Playstore settings the auto update is showing never. If not select it. I've never had a problem afterwards.
Princelee
Explorer
Options
Hi thank you I will try this and let you know if it works for me too
Princelee
Explorer
Options
Hi I'm still experiencing the same issue seems to especially occur as soon as I restart my phone
0 Likes
Bigtasty65
Hotshot
Options
Take a screenshot of your network preferences in your Playstore settings like I've posted below.Screenshot_20230421_171029_Google Play Store_1000002821_1682093429.jpg
0 Likes
Princelee
Explorer
Options
This is my current settingScreenshot_20230421_172355_Google Play Store_1000026862_1682094235.jpg
0 Likes
Bigtasty65
Hotshot
Options
Try changing the app download preference. See if that makes a difference.
Plus, how often do you restart your phone?
0 Likes
Princelee
Explorer
Options
Hi there I've tried this from the last time we spoke and still the same issue persist I think it might of been the latest Samsung update because I've never had this issue b4 also I restart my phone from time to time but since thr issue I've done it more often to check the google play store update issue
0 Likes