Open search

Predictive text not showing after latest Android Update Version 10


Hi there, 


I have multiple keyboards set in Samsung keyboard -> Languages and types. 


The probelm I have, after the most recent update taking place (some week ago now) the predictive text is no longer showing up for russian keyboard. Why? 


I have English, UK and Portugese, they both show predictive text above. But not fur russian. This is very frustrating as I relied on this feature a lot when writing emails etc. 


Could you please share any suggestions and flag a fault for this. 


So far I have tried resetting the keyboard settings and restarting the phone. 


This happened after the latest software update. 




Accepted Solutions
First Poster

Hi everyone, I have managed to find a solution. 

I was having the same issue but mine was more severe as it was not showing any word suggestions, no auto correct, no auto punctuation. I was having to type everything out myself. Very annoying. 

But I've managed to figure it out. You simply need to reset/restore the app. And the way to do this is to go to the app settings and clear all data.

So go to Settings>General management>Language and input>On-screen keyboard>Samsung keyboard. Click About Samsung keyboard. Now click the i icon in the top right hand corner. Click Storage, at the bottom of the screen you will see 2 options > Clear Data and Clear Cache. You want to click on  clear data. Once this is done, your app is now reset/restored. It will now work as normal. 


I hope this works for you. Let me know how you get on. 







View solution in original post

201 REPLIES 201
New Member

Hi  I have the same problem since the last update. No predictive text for English keyboard. Other languages are fine. I appreciate any help.

Same! How can this be fixed

@Hapsit12: If you go to Settings > General management > Language and Input > On-screen Keyboard > Samsung Keyboard > Languages and Types > Tap the 3 dots in the top right > Manage Input Languages > Tap the 3 dots in the top right > Check For Update, do you see a prompt to update next to the Russian language option? If so, tap this option to bring it up to date. If not, go back and select Smart Typing > Predictive Text > On > Auto Replace > Make sure that Russian is toggled on here. Hope this helps.

Hi  AndrewL 


Many thanks for coming back with suggestions. 


I tried both, the first suggestion - all languages were already updated. 

Second suggestion Predictive text was already on, except I enabled Auto replace for russian. This unfortunatelly has made no difference. 


It was all working fine, and predictive text works for other languages (english/portugese) multiple suggestions pop up as you type words, but not fur russian. 


This hapened after the very last updates, I know this because after the update was complete I went on to write an email and was met with this feature missing. 


Please flag this with the developers team and I look forward receving further suggestions. 




I'm also having this issue and have tried all the suggested fixes. Can someone advise as to the resolution please? Starting to think I should just go back to iphone...

I switched keyboards for now...

Got to your settings to do this...

Either switch to Gboard or Samsung keyboard beta (I think its called)


Hope this helps for now

@Hapsit12: Sorry to hear that your issue has persisted. Can you try going to Settings > General Management > Language and Input > On-screen Keyboard > Samsung Keyboard > About Samsung Keyboard, to see if there is an update prompt for the app as a whole. If not, you could try 'Reset To Default Settings > Reset Keyboard Settings', although please be aware that this will remove any personalised settings, requiring you to set them back up. Let me know how you get on.

I've read the earlier comments. Since this week's update to Android 10, my S9 no longer offers predictive text for the Samsung keyboard in English, French or German. I have checked for updates, to no avail. Not happy. Please ask the developers to find a fix.

Doesn't work for me.
Top Liked Authors