Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Problems with 4g connectivity after software update on A71 phone

(Topic created on: 14-07-2021 01:33 PM)
Fort William
Apprentice
Options
Galaxy A Series

I updated the software on my A71 on Monday 12th July and now cannot get some of the apps to work on 4G - namely ' Google ', 'Google Play', ' Amazon ', ' YouTube ' and a few others but all the apps do work normally on wifi. I have checked with Vodafone ( my provider ) and there no issues with my data plan. I did take the sim card out and check it out in an old iphone 6S - all the apps worked fine on 4G so it is not a data mobile problem. I am able to send/receive e mails and WhatsApp messages on 4G on the Samsung with the sim card installed.

I did spend over 2 hours yesterday with an online Samsung help chat but with no success and I have gone through all the install/uninstall help videos on YouTube and Google I can. 

Any suggestions please?  

0 Likes

1 Solution


Accepted Solutions
Solution
ecosse01
Pathfinder
Options
Galaxy A Series
Correct config. Screenshot_20210714-205153_Settings_10666.jpg

View solution in context

0 Likes
11 REPLIES 11
Pugs1957
Superuser I
Superuser I
Options
Galaxy A Series
Just add Vodafone APN in settings, connections, mobile networks, Access Point Names. They messed-up big time.
ecosse01
Pathfinder
Options
Galaxy A Series
I had exactly the same issue. Tried 4 different SIMS from family members in my A51 5G and none would work, must be the phone, right?

Called Samsung support and paid £20 for the WeFix service, they come to you under warranty and sort within an hour.

Only thing is that after 2.5hrs, the engineer could not get the A51 5G to work on my SIMS, just his O2 SIM!

I had to phone Samsung 5 times to get another engineer visit sorted.

The night before the visit, I was once again googling and found this page to add the APN. I must stress, I did contact Vodafone and they sent me a brand new SIM, delivered the next day, same no data result.

I added the APN as per this website and it just worked:
https://deviceguides.vodafone.co.uk/samsung/galaxy-a51-5g-android-10-0/connectivity/set-up-your-phon...

I managed to work out that the config message being sent by VF to the device is not being implemented accurately as it's adding a proxy server address where one's not needed and a port ID.

Try the above as mine is now happily flying on 4G.

Good luck 🤞
0 Likes
ecosse01
Pathfinder
Options
Galaxy A Series
Incorrect config. Screenshot_20210714-205051_Settings_10664.jpg
0 Likes
Solution
ecosse01
Pathfinder
Options
Galaxy A Series
Correct config. Screenshot_20210714-205153_Settings_10666.jpg

View solution in context

0 Likes
Fort William
Apprentice
Options
Galaxy A Series

Many thanks for your reply. I tried everything with a Vodafone regarding the mobile data settings but with no success. I had to have the 'phone remotely connected with Samsung technical support for over an hour and a half for a full factory reset - still no luck whatsoever. Will wait until a Samsung engineer can visit to sort it out.   

0 Likes
Fort William
Apprentice
Options
Galaxy A Series

Many thanks for your reply. I will get my son to look at this as he is very tech savvy before calling the Samsung engineer. Your help is appreciated. 

0 Likes
Fort William
Apprentice
Options
Galaxy A Series

Many thanks indeed for your solution - much appreciated. 

ecosse01
Pathfinder
Options
Galaxy A Series
Did this config also work on the 71 device? Interesting if there's a few devices not correctly implementing the config msg.
0 Likes
Fort William
Apprentice
Options
Galaxy A Series

Hi. Yes it did work first time for me - I was about round the twist with talking to Samsung Product Support, Vodafone and then Samsung Tech Support. A full factory reset did not cure the issue. 

I did the update on Monday morning whilst staying in a Victorian B&B in Grantown on Spey. The walls a re solid granite and the WiFi not so good so it looks like the update took too long to download and caused the problem. The strange thing is that Vodafone has the best coverage of all the mobile providers in that area. Strange!