Support

Open search

Not getting WhatsApp notifications consistent with my current settings

Highlighted
SOLVED
Apprentice

Mu phone is a Samsung Galaxy A20s.   

I'm struggling with an extremely frustrating issue. When I get a WhatsApp message, my phone won't vibrate and play the notification sound. I have the always-on screen enabled and I can tell I have a new message because the icon and the message itself is on the screen, however my phone usually lives out of my hands so I end up missing messages because WhatsApp won't vibrate and play sound.

I've tried all kinds of well known methods to fix the issues but nothing worked well so far. 

Has anyone had similar issues, or know of any fixes?

Thanks!

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Thanks for the reply

 

I already did what you said and it didn' work so I decided to restore everything and it worked!

 

I was able to fix the issue, finally!

View solution in original post

5 REPLIES 5
Highlighted
Moderator
Moderator
@aquariusfish: Do you get sound and vibration for notifications while the phone is unlocked, or does the issue persist? Is Whatsapp the only affected app? As a troubleshooting step can you try disabling the Always On Display to see if this helps? Also, if you go to Settings > Apps > Whatsapp > Notifications > On, then check all the available sub settings (such as New Messages), do you have 'Sound and Vibration' selected as the notification type? Can you also double check that lock screen notifications are enabled with sounds and vibration by going to Settings > Lock Screen > Notifications. Let me know how you get on.
Highlighted

Hi

Thanks for the reply

I've done what you've said and other things in other threads and YouTube have recommended to me but nothing worked completely well so far

Now I was able to make the phone vibrate when receiving messages but I still not getting the sound of notification

 

Highlighted
So only now I've found  out I'm without sound for notification coming from any messaging app not just whatsapp now.

The phone only vibrates.



Did I screw up with something I shouldn't have?  And I don't know where so I can't go back to fix my mistake easily
Highlighted
@aquariusfish: If you swipe from the top of your screen to the bottom, can you see 'Sound' in the quick settings menu, with a speaker thumbnail? If not, and you can see 'Vibrate' instead, then tap this option until 'Sound' is selected. Also, go back to Settings > Lock Screen > Notifications, and make sure that all available notification styles are set to 'Sound' or 'Sound and Pop up'. Do the same for Settings > Notifications, and you should be good to go.
Highlighted

Thanks for the reply

 

I already did what you said and it didn' work so I decided to restore everything and it worked!

 

I was able to fix the issue, finally!

View solution in original post