Support

Open search

I have a new A20e on which my house wifi keeps disconnecting. This didn't happen with my previous S7 so it seems a problem with

Highlighted
First Poster
 
13 REPLIES 13
Highlighted
Moderator
Moderator
Hi @AJP1, is your phone's software up to date? Check in Settings > Software update > Download updates manually. Can you also check if you have Power saving mode on? Turn this off as Wi-Fi uses up some of your phone's battery power and it may disconnect from Wi-Fi to conserve battery. This will be in Settings > Device maintenance > Battery.

Let me know how you get on.
Highlighted
First Poster

Thanks for the reply. Sadly the problem persists. I downloaded the software updates. The battery is set on 'Optimised' not Saver. The wifi keeps randomly disconnecting. I have rebooted the router. As I said, the wifi was fine with my previous Samsung S and with my laptop. This seems a well known problem for Samsung so I wish they would sort it out! Regards Andrew

Highlighted
Moderator
Moderator
Thanks for this. Some routers have MAC filtering on them, which is a security access control method. This means only a set of certain devices can gain access to your Wi-Fi.

Does the router have a MAC filter? If you're not sure, check with your Wi-Fi provider.
Highlighted
First Poster

Thanks. I could check with the router provider, but I don't understand how it could be a security access control, as the wifi does work with the phone but keeps dropping out. If the router was refusing access wouldn't it not work at all?

Highlighted
Moderator
Moderator
I just want to check this, as the next step would be to backup and factory reset the phone.
Highlighted
First Poster
I have a BT Home Hub 4. I dread the thought of phoning BT Help, would no doubt have to wait hours. I found a manual for HH4 which doesn't seem to mention PAC. I found the advice below on a forum though which suggests MAC filtering doesn't exist on this Hub. I don't have hours to spend on this, I just want a phone that works!!

https://community.bt.com/t5/Archive-Staging/MAC-address-filtering-on-HH4/td-p/1597629
Highlighted
Moderator
Moderator
Understand the frustration, I want to get this sorted out. Have you tried backing up and performing a Factory reset?
Highlighted
First Poster

Hello, thanks. I have done a re-set (holding down the Off/On and Vol down buttons). This seemed to work for about a day, then unfortunately it started disconnecting the wifi regularly again. I am thinking, as this A20e seems defective Samsung should agree to replace it - I'd be happy to have a S7 again which didn't have this problem

Regards Andrew

Highlighted
Moderator
Moderator
A Factory reset wipes the phone completely and restores it to Factory settings. That's different from the Soft reset. Do you want instructions on how to backup and perform it? This will be the last troubleshooting step before looking at arranging a repair.
Top Liked Authors