Support

Open search

A70 screen will not dim/USB connection.

Highlighted
Apprentice

Hey,

 

I've noticed a problem with my A70 regarding trying to dim the screen when locking manually or expecting it to lock after screen timeout.

 

Basically, my phone won't sleep, at least not whilst charging. I spent a good while playing around with settings on my phone, such as timeout and lock screen settings. I also powered off the device but no luck.

 

After trying to figure out the problem further I discovered that the notification tray is being constantly updated every few seconds swapping between "Android system USB connector connected" and "Android system USB connector disconnected". So presumably this is what is keeping the phone awake as it thinks it is being constantly connected and disconnected from source USB source. I cleaned out the USB port but it was pretty clean to begin with. I'm not getting any notifications regarding any moisture detection.

 

The A70 charges just fine (though sometimes there is a slight delay to it recognising being plugged in) and it seems that the USB tethering interface is working well as I can use the remote debugging feature in Google Chrome (for web development purposes) just fine. As far as I can tell, there are no actual issues with the USB port - it functions as I would expect.

 

The A70 was last updated on the 14th August to "Security Patch level: 1 July 2019" and looking over the log of updates I see that "The charger/USB port's moisture detection algorithm has been improved" - so someone somewhere has been looking at this feature and I doubt it coincidence that my device has just developed a fault, given that I've not had it anywhere near moisture or excessive dirt.. and the port still actually works!

 

I've also tried Safe Mode but the issue persists. Also, if I power the device off, then plug it into the wall, power it on, the notification issue stops... until I unplug it/switch off the wall socket - then it comes back again.

 

Anyone else having similar problems?

551 REPLIES 551
Highlighted
Can you maybe explain step by step what you did. Bc i don't know what u mean with the dialler.

Thanks in advance
Highlighted

It seems to start once the phone has gone to "sleep" and been woken up. It happens in Safe Mode too as power management is handled by Android / firmware.

There may also be a hardware issue, dunno...

Highlighted

Did factory reset.

All fine till it went to sleep. When it woke up, same problem.

Highlighted

gaplayer27's solution is working for me

 

On your phone go to the dialler, the bit where you would put the numbers in like you're going to make a phonecall.

 

Type the numbers gaplayer27 said, *#0808#

You have to physically type them, not copy and paste.

As soon as you enter the last character the screen he said will appear. It's some kind of low-level USB mode override.

Select the bottom option.

Click apply.

 

Repeat and make sure the bottom option is still selected then hit the other button at the bottom which is "Reboot".

 

My guess is there's a problem with the USB drivers when coming out of sleep mode and they hit some sort of infinite loop, and this resets them. But that couldn't possibly be the case could it? Wouldn't it have been picked up in integration testing on the firmware?

Highlighted

I've tried this and it didn't fix anything.

Highlighted


@Iets wrote:
Can you maybe explain step by step what you do. Bc i don't understand what u mean with dialler


A70_DiaUSB_SettingsMenu.jpg

As soon as you press the last '#' symbol the USBSettings menu should open automatically, good luck!

 

 

Highlighted
Yes, I foiund I had the same problem in safe mode too 😞
Highlighted

it works temporarily. Was just charging with a dodgy in-car charger and it's set it off again...

Highlighted

having the same problem since sunday, tried every solution i can find and nothing works. it's getting really annoying... 

Highlighted

While the phone is on, press volume down and power button for 10seconds till the phone restarts. I think this works.

Top Liked Authors