Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

A54 5G USB - connectivity issues all of a sudden

(Topic created on: 30-04-2024 02:28 PM)
580 Views
Trikepilot
First Poster
Options

I have an A54 now for less than a year that has been great so far. But about 2-3 weeks ago, I had a strange situation pop up with the USB port. 

I keep a cord permanently in my car for android auto. And for over a year it worked flawlessly, but then out of the blue I get the message that the cord is not correctly connected and to try a new cord. I gathered all of my cords and tried them all - close t o20 of them - and I get the same message. What are the odds that all 20 cords are not compatible?

I also use a SD card reader that I plug into the USB charging port and pull images from a game cam. At the same time as the problem above, I can no longer get the A54 to recognize this card reader. it works fine on my tablet still. 

And the cord that has sat at my bedside for years without issue, now is finicky when you plug it in and I get the Samsung warning that I need to make sure that the cord and charger are plugged in correctly and I should try a new cord. This is the same cord and charger I have used for years. 

these issues all happen on any cord and charging brick combo I use - oem, aftermarket, built into car, or any other. So it makes me think that there is a problem with the phone itself. Was there an update that scrambled the USB port settings for car connectivity and charging? What options do I have? Very frustrated... 

0 Likes
4 REPLIES 4
Robin999
Maestro
Options
Have a close look into the port. Look for any fluff, dirt, etc. Gently blow into the port to try and dislodge any dirt, etc. Try to refrain from poking any metal objects in there to try and clean it as this may cause irreparable damage. Can you recall if the port got any water or other liquids split in it?
You may need to take it into an authorised Samsung centre to have it inspected.
OmegaMutant
Voyager
Options
Could also try clearing cache and data from USB settings app c

Settings > Apps > click on arrow with three lines (just above the apps list) > Toggle on Show system apps > OK > USBSettings > Storage > Clear Cache and Clear Data then restart phone
Trikepilot
First Poster
Options

Robin999 and OmegaMutant - I have tried both of these suggested fixes with no resolution. I have googled the problem extensively to no avail. 

0 Likes
Robin999
Maestro
Options
Possible the problem could be deeper into the port or maybe where it connects to the main board. Impossible to tell unless inspected properly by a technician.

If the cache clear didn't work, then you could try a cache partition wipe

You would need to plug into a working PC or laptop (unsure what bearing thus would have on your dodgy port)

https://www.samsung.com/uk/support/mobile-devices/how-do-i-clear-the-cache-on-my-device/

Failing that and a bit drastic, I know, but consider full factory reset. If that fails then I'd get it looked at professionally.
0 Likes