Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

samsung oddysek ark disconnecting with Game Mode On

(Topic created on: 09-02-2024 06:38 PM)
629 Views
CNP
First Poster
Options

I've had the Samsung Odyssey Ark for several months now and a problem persists that is making this monitor unusable at times. In short, when loading into a game, with the Game Mode On option of the monitor and Input Signal Plus On, in order to get 165Hz, the screen will often turn black. Sometimes immediately when loading into a game, other times some minutes into the game. Turning the monitor on and off does not help. The only thing that helps is turning Game Mode Off, thus limiting the monitor to 60Hz. Then the image comes back. After exiting the game, even when I turn Game Mode On again, the image will mostly be okay.  Though sometimes it happens that the monitor completely loses connection with my PC, saying that there is no HDMI connection. Restarting the computer usually fixes this.  I have tried adjusting many monitor settings, turning the box on and off, disconnecting and reconnecting all the cables.  Nothing seems to do it. I have bought several high quality HDMI cable to try, but it made no difference. I had hoped the problem would go away as the software of the Odyssey Ark get updated, but it has not. I am thus desperately asking for help on how to address this. Should I ask for the monitor to be serviced?

Finally, the problem seems to have been encountered by other people, as illustrated by this Reddit post: https://www.reddit.com/r/OdysseyArk/comments/yphrju/odyssey_ark_constantly_disconnecting/

0 Likes
2 REPLIES 2
tboo72
First Poster
Options

Im having the same issue and I have a Radeon/Ryzen setup. Monitor loses signal for a few seconds when playing games. Getting a different HDMI cable didnt help. Turning off FreeSync helps a little, it happens less often but it still happens. Frustrating

0 Likes
xxNiradxx
First Poster
Options

I'm having the exact same issue on my Odyssey Ark Gen 2 which I received about a week ago.  I'll randomly lose signal during gaming for a few seconds with a black screen and spinning wheel but recovers after like 5 seconds.

Only happens with running 4k @165hz which I understand requires Display Stream Compression (DSC).  My brother has the same monitor and he exhibits the exact behavior some I'm confident his is not hardware issue but rather a driver or firmware issue.  I've seen countless threads on this topic but Samsung doesn't seem to be addressing it since it dates back the Ark Gen1 monitor is well. 

Samsung really needs to address this since the 4k @165hz is unusuable and this is absolutely unacceptable for the cost of this monitor.

 

  

0 Likes