Open search

Samsung DP700a7d AIO

New Member



Hoping someone can help. I have a Samsung DP700a7d AIO that I need to get into the BIOS/Boot Menu. The user manual suggests pressing F2 on boot several times. I have done this & have also tried a different keyboard but just cannot get in!!


Many thanks in anticipation


@Gatsoman: Sorry to hear that your having trouble accessing the BIOS menu. All I can suggest is pressing the F2 key repeatedly and continuously, immediately after powering on the device, until the BIOS menu appears, as I wasn't able to find an alternate means of accessing it in the user manual. If possible, use a wired keyboard to avoid any connectivity issues. 


Many thanks for that. Yes have tried 2 different wired keyboards & still no joy though! Could the F2 feature have been turned off by someone else? Are there any other ways in - maybe just a separate boot menu option?




Hi Andrew (again!),


Success!! I already spotted that there was a wireless keyboard/mouse dongle plugged into one of the bottom USB ports & I removed it. However whilst scratching my head I was looking around the casing of the AIO & found the little door on the left hand side which has additional USB ports & ab SD card reader. There were two more wireless keyboard/mouse dongles plugged in. Really puzzled as to why my client has 3 of these devices plugged in!! Anyway removed these & hey presto - straight into the BIOS!!!


Many thanks




Top Liked Authors