Support

Open search

980 Pro 1TB - BitLocker (eDrive) encryption - is it working for anyone?

Highlighted
SOLVED
Apprentice

Hello,

I bought Samsung 980 Pro 1TB recently. I have an issue with enabling HW encryption in BitLocke (eDrive). No matter what I do, drive stays in "ready to enable" state in Magician. I contacted Samsung directly, but so far no useful info. I set group policies in Windows to allow for HW encryption, I did diskpart clean and reinitialized the drive in Windows, but it does not work at all. I have no problems with encrypting my other Samsung drives - 850 EVO and 860 EVO, but 980 is no go.

 

I am using Magician ver. 6.2.1 and firmware 1B2QGXA7.

 

I wanted to make sure that enabling eDrive is possible with current FW on this drive, before I spent even more time on this. AFAIK 960 Pro had to get a FW update to support eDrive, so maybe this is also the case here.....

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Apprentice

I got the answer from the support to which I was pointed to and my issue is solved now.

 

I had to disable "Block SID support" in BIOS. On my board it can be disabled only "for one boot" (meaning that after reboot the setting will toggle again to enabled), but it was enough. Just put the SSD in "ready to enable" state, diskpart clean the drive, then reboot, disable "Block SID support", boot into Windows and initialize the drive using Computer Management, create partition and enable BitLocker.

 

Thanks for help everyone.

View solution in original post

8 REPLIES 8
Highlighted
Moderator
Moderator

Hi @TurboJelly 

 

We have a specialist team set up to deal with these types of query who may be able to give you some advice. You can contact them as follows:

 

Hope this helps!

Highlighted
Apprentice

Thanks. I have sent an email, lets see if I get an answer to my question.

Highlighted

Hi @TurboJelly , Just seen this one. Appears Chris has got his Hanwha's and Hanaro's mixed up - sorry about that!

 

Hanaro are the guys you want for Samsung SSD's:thumbs-up-sign-emoji-modifier-fitzpatrick-type:

 

  • Email: samsungmemory@hanaro.eu
  • Telephone: 00800-8010-8011

 

(Hanwha deal with home security/CCTV stuff, if you're ever interested though.)


Highlighted
Apprentice

Thanks for clarification I mailed samsungmemory@hanaro.eu and I am waiting for an answer from them.

Highlighted
Apprentice

I got the answer from the support to which I was pointed to and my issue is solved now.

 

I had to disable "Block SID support" in BIOS. On my board it can be disabled only "for one boot" (meaning that after reboot the setting will toggle again to enabled), but it was enough. Just put the SSD in "ready to enable" state, diskpart clean the drive, then reboot, disable "Block SID support", boot into Windows and initialize the drive using Computer Management, create partition and enable BitLocker.

 

Thanks for help everyone.

View solution in original post

Highlighted
First Poster

@TurboJelly, do you see TCG Command error 10 (AuthenticateSession) from EnhancedStorage-EhStorTcgDrv in System Event Log everytime you power on the machine?

Highlighted

@puppy2016 I actually do get it, never checked for this before and I only looked at it after your post. No idea what it means, but everything seems to be fine with the drive. I currently have my 980 Pro as non-system drive with HW encryption from BitLocker enabled.

Highlighted

@TurboJelly Thanks for the confirmation. I plan to use it as a system drive that makes it harder. I was able to get the hardware encryption work, but when I turned the BitLocker off on the system drive, I wasn't able to enable it again. I got error message that the software encryption is available only (I disabled it in Group Policy). Does it mean it is only one time available and I would have to erase the system drive in order to enable it again?

Top Liked Authors