Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Samsung WAM6500 R6 Multiroom Speaker LEDs & Volume Buttons No Longer Work

(Topic created on: 26-11-2020 09:35 PM)
Ripperoo
Pioneer
Options
Audio & Video

I have quite a few of the Samsung Radiant R6 range of Multiroom Speakers (4 x R1 WAM1500, 2 x R3 WAM3500 and 3 x R6 WAM6500) and have them all working effortlessly within Samsung Multiroom, except for one!.

 

One of the R6 (WAM6500)!

 

This speaker was 'shelved' a while back after it would randomly increase/decrease the volume while playing music when grouped in Samsung Multiroom.

 

So a few days ago, after about 6 months on the sidelines, I decided I may as well use it in my son's newly re-modelled bedroom as a standalone bluetooth speaker.

 

But it was not to be.....well, kind of!

 

After initially plugging it into the mains to charge up, no LEDS were lighting up, so left it to charge overnight.

 

Same the next day though!

 

Pressed various button combos to no avail and was about to trash it when I thought I'd see if it was appearing in Samsung Multiroom.....and it was there, with a fully charged battery, but still not LED indication on the front panel.!

 

So I launched a Tidal playlist and it played fine, but although I could increase/decrese the volume from within Samsung Multiroom, I could not do so via the controls on the speaker itself.

 

I'm guessing therefore that there must've been an issue all along with R6 WAM6500 front-panel circuit board, which caused the volume issue and which must have somehow got worse to the point of being fatal while the spekaer was out of action.

 

It's well out of warranty, so I need to know if there is a way to dismantle this speaker and check to see if any ribbon cables have came loose.

 

Checked Youtube to no avail.☹️

0 Likes
0 REPLIES 0