Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Issue with HW-N950 rear speaker

(Topic created on: 04-11-2019 05:46 PM)
4176 Views
MichaelAmherst
First Poster
Options

I've noticed that the right rear speaker for my HW-N950 set up keeps losing connection. It goes to a blue blinking light when the soundbar is off. Pressing the speaker ID button does nothing. Going to ID SET on the soundbar reestablishes the connection. However, when the system powers off the issue recurs. I think it's an issue of the rear speaker not powering off (to the red light) as the others do. Any ideas the solve this? It means having to reestablish the connection every time I power the system on. 

0 Likes
4 REPLIES 4
CarloL
Hotshot
Options

Hey @MichaelAmherst! Follow the steps below to reset the system:

 

Please note do not use anything sharp or metallic to carry out the following steps.

 

Use an implement to press and hold inside the reset hole for 5 seconds, wait for all LEDs to flash.

 

Unplug the hub and wait a moment before plugging it back in again.

 

Please unplug all speakers from the hub and wait a moment before plugging them back in again.

 

Please note without disconnecting and re-connecting the speakers manually the connection will not work.

 

2. Reset your speaker(s) by following the steps below

 

Press and hold both the + and - buttons simultaneously for 5 seconds to reset the product

 

3. Initiate the 3 step setup guide.

 

- If Hub and/or speakers pairing indicator aren't flashing, press the Add Spk Button on all devices which are not.

 

- Once the pairing indicators are flashing, press and hold Add Spk button for 5 seconds again on the Hub to force pair.

 

- Turn off and restart your Phone or Tablet.

 

Did this help? 

0 Likes
MichaelAmherst
First Poster
Options

Hi CarloL,

 

Many thanks for your reply. Sorry I'm a bit confused as to what you mean by the hub? The rear speakers are only plugged into a power socket and connected to the soundbar wirelessly right?

 

Best,

Michael

0 Likes
Cédric Bernard 22
First Poster
Options

Hi Michael, did you succeed to solve the problem?

I have exactly the same behavior, the firmware is the latest one but the surround speakers keeps disconnecting randomly 

0 Likes
Baihui
First Poster
Options

I have exactly the same problem with my hw-n950 soundbar. The rear speakers keeps disconnecting and also Bluetooth connection to iPhone and MacBook Pro keep disconnecting also. This is definitely a firmware issue but Samsung just does not care to release an new firmware’s update as this such an old devices and it does not matter it was the top model back in 2019 and we spent a lot of money!

0 Likes